Jump to content
Sign in to follow this  
dansidi

Crowd - Randomize Heading does nothing

Recommended Posts

Hi,

 

Can anyone explain how to use the Randomize Heading parameters on the Crowd Source?

They don't seem to have any effect at all.

I have set Velocity to zero, but still no luck yet.

 

Any assistance would be great.

 

Many thanks!

Edited by dansidi

Share this post


Link to post
Share on other sites

It works, you just have to solve it in order to see the result.

Share this post


Link to post
Share on other sites
vector look = set(fit01(rand(@ptnum), -1, 1),0,fit01(rand(@ptnum*23), -1, 1));
vector up = {0,1,0};

@orient = quaternion(maketransform(look, up));

matrix m = qconvert(@orient);

v@v = {0,0,1} * m;

So, my colleague gave me this voodoo to put in a wrangle BEFORE the Crowd Source node.

It does the job, but still leaves me wondering what the Randomize Heading parameters are for on the Crowd Source

Share this post


Link to post
Share on other sites
2 minutes ago, rayman said:

It works, you just have to solve it in order to see the result.

It doesn't - I was solving the crowd and it wasn't doing anything.

Thanks for replying, though :o)

Share this post


Link to post
Share on other sites

Maybe a problem with your build - I just tested it and it was working fine. Houdini 18.0.287

Share this post


Link to post
Share on other sites

18.0.348 here.

Thanks for trying it.

It's obviously user error, but I can't see what it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×