Jump to content
Sign in to follow this  
lavitz01

Redshift and %(UDMI)d issue

Recommended Posts

I am tring to assign either .tiff or .rstexbin files to my character that i am using for RBD. when i assign the textures to the character, they seem flat even though i assigned the displacement map. The character have at least 4 UV sets per texture it seems. is there an easy way to create all of the groups needed since the character has at least 12 different objects that were merged together before being packed. I unpacked the geo and could se the uv sets that were all layered on top of one another. i have 25 different texture maps and i am having to select the polygons individually and then group them to use a material sop to assign to the group. if there is an easier way about this please let me know.

I have attached url for the textures and the hip file.

https://drive.google.com/uc?id=1mjLxLb2AWJcL2qAZTXe0fIVlP860Ku78&export=download

 

DinoCharacterHelp.v01.hipnc

Share this post


Link to post
Share on other sites

Here are a few things to get you started:

It's strange that the model is a mix of UDIM and non-UDIM textures.  Normally I would lay out the uv's so that each has it's own island.  As you mentioned, there is a lot of overlapping geo in the 1001 UDIM space, so offsetting would make it easier to deal with.  For this, you'd need to follow the UDIM workflow, and append the %(UDIM)d variable to each filename.  To offset the UVs, add a UV Transform node to each group.  Honestly, it might be a lot of extra work, considering there are only 15 non-body textures.

Setting up groups is common, so you should be ok to create a material for each group and assign it as you have been.

To fix the displacements: in the shader networks, you need to pipe the displacement textures through a RS Displacement node, and then adjust the scale.  Then on the obj node, enable tessellation and displacement.

The images below show with and without the displacement (and added roughness maps).

Screenshot_20.png

Screenshot_21.png

Edited by Howitzer99

Share this post


Link to post
Share on other sites

One other thing: to make your texture paths more portable, you can use <UDIM> instead of %(UDIM)d.  It's more of a standard naming convention between packages for loading UDIM tiles.

Share this post


Link to post
Share on other sites

nothing is necessarily overlapping, the file contains 35 objects, each can have different material, or more objects can have the same material, but overall it was for sure designed that all objects with the same material will have nonoverlapping uvs

the question is, why are your objects not properly named ?

/file1/file1
/file1/file1_1
/file1/file1_2
/file1/file1_3
...

if you exprted the alembic, make sure you preserve object names, it will make matching them with materials much easier, potentially even fully procedural

Share this post


Link to post
Share on other sites

The way the object is and naming conventions are how it was provided.  I agree that <UDIM> is most universal for maya max and any 3D packages but some forums I can across said that Houdini needs the % proceeding and the truncated d to correctly interpretation multiple UDIM’s. I could be wrong, but I could not tell the difference between using either version. It might just be the difference in read and write speeds or data interpolations. 
 

two issues I have found is that after I group split and group the nodes and add a transfer uv sop, and translate 1 unit in x, the textures become lost or stretched. It seems that and I’ve translation destroys the uv position in relation to the uv sets. In regards to displacement I added the RS displacement and also the RS object and enabled both tessellation and displacement. When I did this, the skin for the most part looked fine but the eyes and mouth became very distorted and seemed to have rotation and height maps injected. Without displacement it is smooth and then become jagged once applied. It is the same with or without the map. Can you control the intensity or area of displacement or apply a mask? I tried to lover the intensity to 0.0001 but it had no effect until I applied a value of 0.

thank you for everyone’s time and help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×