Jump to content
Sign in to follow this  
pizola

Redshift Render Settings Slow?

Recommended Posts

Posted (edited)

I am reaching the final stages of a personal project of mine and I was wondering if this render times were okay for the setup I have since I swapped to redshift 3 days ago:

1070 ti 8gb

ryzen 9 3900x

32gb ddr4 3200mhz

It takes 40 to 50 minutes to render the following (no DOF nor mortion blur):

NOTES: The scene consists on bolts and sparks with incandescent material + the emisssive sword, 2 Volumes (you are looking at the smallest one which is around 8million voxels) + 3 mesh lights inside the capsule (bolts, sparks and a scorch on the impact area of the bolt) and 3 others spread around the scene (the Highlighted ones)

image.thumb.png.34e2242bde2a3d92afcf5424b5c010cb.png

EDITED:

5ec7800117cdb_Final.v02(0-00-00-00).thumb.png.5f1a395eec60e119f8e8daacfb14dc9d.png

NOT EDITEDFinal_v02.thumb.png.ba5e2c2e4497eb78a41b9a7372a8ed45.png:

These are my settings:

image.png.02cce07e9830a566f0132a59628a6438.pngimage.png.4f546823b5ab4d30708c441f875c115e.png

image.png.6d2cdb192ac5ccd6d57f4121e849de26.png

image.png.45f02f970cea6eeb232ba37fca1fc463.pngimage.png.b92f2256da2e3d4bef874594854c8eb3.png

In all mesh lights I copied the override sample values because I dont trust it xd and all have 64 bounces for volumes too.

image.png.fc9c22bc081ce5c2110d59de6ecaa387.png

I hope more experienced artist can help me out with this one if you find something odd in my project. 

As always, thank you very much :D

image.png

EDIT: No, I wont be using the Optix denoiser and this is how the noise on my scene looks:

image.png.a08f905c4e0bf797f9dc93d7e43cd3d7.png

Edited by pizola
Missing info

Share this post


Link to post
Share on other sites

A couple things off the top that might help are:

Disable the Progressive Render override.  You would want to use the bucket method for final renders, progressive is meant for interactive rendering, and is not as accurate (doesn't support all render options).

You are throwing a lot of rays into the scene, so yea, I would expect it to take a long time.  Can you optimize this or split layers?

For reducing noise, lowering the Adaptive Error Threshold below 0.1 will result in cleaner renders, but will be longer to render.

 

Share this post


Link to post
Share on other sites

Your settings are really really high.
If your not an redshift expert, let the defaut setting do the job.
Usually in most cases you just have to adjust min and max sample :  8 - 128 or 256 work well in most of the case.
And adaptative error threshold : 0,005
Eventually up a bit the GI bounce, but more than 8 doesn't really give better visual result.
Let bute force GI ray by default.


as Howitzer99 say disable progressive sample as it's mainly for preview purpose (by the way 128 it's ok)

Avoid raising all parameters in the sampling overides section, as if you don't know what you do, this can result in bad performances.

Test like this.


If you get some noise Try to find out where the noise comes from : reflections, refraction, lights etc...
If the reflection on a particular object is noisy, up the reflection sample in the object's material.
If your volume are a bit noisy up the volume sample in the light who have volume contribution.

Hope the help.

Share this post


Link to post
Share on other sites
11 hours ago, Howitzer99 said:

A couple things off the top that might help are:

Disable the Progressive Render override.  You would want to use the bucket method for final renders, progressive is meant for interactive rendering, and is not as accurate (doesn't support all render options).

You are throwing a lot of rays into the scene, so yea, I would expect it to take a long time.  Can you optimize this or split layers?

For reducing noise, lowering the Adaptive Error Threshold below 0.1 will result in cleaner renders, but will be longer to render.

 

Hello, I am testinf different render settings atm. What do you mean by spliting layers?

 

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, flcc said:

Your settings are really really high.
If your not an redshift expert, let the defaut setting do the job.
Usually in most cases you just have to adjust min and max sample :  8 - 128 or 256 work well in most of the case.
And adaptative error threshold : 0,005
Eventually up a bit the GI bounce, but more than 8 doesn't really give better visual result.
Let bute force GI ray by default.


as Howitzer99 say disable progressive sample as it's mainly for preview purpose (by the way 128 it's ok)

Avoid raising all parameters in the sampling overides section, as if you don't know what you do, this can result in bad performances.

Test like this.


If you get some noise Try to find out where the noise comes from : reflections, refraction, lights etc...
If the reflection on a particular object is noisy, up the reflection sample in the object's material.
If your volume are a bit noisy up the volume sample in the light who have volume contribution.

Hope the help.

So I followed your and @Howitzer99 (thanks bro) guide and made a render study with different settings. I managed to halve my Min and Max samples 32 and 512 now, I lowered the error thresshold to 0.005 and most importanly I changed the secondary GI to irradiance point cloud. The last improving my render times up to almost 2x faster and it looks even better (I am currently testing this but I think it will be 2x times faster).

EDIT: I rendered in 37 minutes (10 min faster) at a lower treshhold and half of the samples but an overall better quality. 20% faster. Ill try with the same threshold and update

EDIT 2: 27 minuts (20 min faster) 45% faster

Edited by pizola
Info

Share this post


Link to post
Share on other sites
Posted (edited)

Have you tried the automatic sampling in 3.0? You can enable it in the System tab.

Edited by DaJuice

Share this post


Link to post
Share on other sites

Can you tell us what is the resolution of your render.
27 minutes still seems like a long time, but if your image is 8 or 16k it can be ok.

I think you can lower min samples to 8. I personnaly never go over except in special cases.

Can you try a render with 8-512 and another with 8-256. Normaly second render time must be half the first.
If it's not the case there is something in your scene causing the problem.

I suspect  the volumes. Do they encircle the camera ?

Share this post


Link to post
Share on other sites
10 hours ago, flcc said:

Can you tell us what is the resolution of your render.
27 minutes still seems like a long time, but if your image is 8 or 16k it can be ok.

I think you can lower min samples to 8. I personnaly never go over except in special cases.

Can you try a render with 8-512 and another with 8-256. Normaly second render time must be half the first.
If it's not the case there is something in your scene causing the problem.

I suspect  the volumes. Do they encircle the camera ?

1280x720. It takes 8 min on a simple shot without volumes and 27 minutes on a complex scene with the settings above. Is it wrong?

 

Share this post


Link to post
Share on other sites

Can you show what you name a simple shot ?
cause 8mn for 1280x720 simple shot seem a long time.
For volumes it depends on density and transparency. A far opque dense smoke don't take much time. On the other side transparent vaporous volume can require high settting thus up the render time. It's cases where I use denoiser.

Can you post a file of the 8mn "simple shot" ?
I have a little station with 1660 super which is roughly equivalent to your 1070 ti

Share this post


Link to post
Share on other sites
Posted (edited)

 

6 hours ago, flcc said:

Can you show what you name a simple shot ?
cause 8mn for 1280x720 simple shot seem a long time.
For volumes it depends on density and transparency. A far opque dense smoke don't take much time. On the other side transparent vaporous volume can require high settting thus up the render time. It's cases where I use denoiser.

Can you post a file of the 8mn "simple shot" ?
I have a little station with 1660 super which is roughly equivalent to your 1070 ti

sry for the late response, OD force doesnt let me upload pictures somehow so I used Imgur; Anyways:

Simple (there is noise but "Acceptable")
lQx0ids.png

Complex with some noise on the volume:

iAKeIDE.png

image.png

OMG ignore this last picture of coronavirus I seriously cant erase it from the post, I dont know how it got inserted

Edited by pizola
Mistake

Share this post


Link to post
Share on other sites
Posted (edited)

That's exactly what I meant. Transparent Volume on the foreground. The worst-case scenario for the render time.
It seems normal to have a rendering 3x longer than the "simple" scene.

is your volume material is emissive ?
How much lights contribute to the volume ?

In this case contrary to what I said above, it may be necessary to raise brute force samples.
You can also try to clamp the rays, set the max sub sample intensity to 1 (Sample filtering section)
Also avoid to light the volume with mesh lights.

However 8mn for the "simple" scene seems too long for me.
but honestly, it's hard to say what's going on, without looking at the file.
So much interactions between materials, lights, and settings, in your project can lead to these results !

Edited by flcc

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, flcc said:

That's exactly what I meant. Transparent Volume on the foreground. The worst-case scenario for the render time.
It seems normal to have a rendering 3x longer than the "simple" scene.

is your volume material is emissive ?
How much lights contribute to the volume ?

In this case contrary to what I said above, it may be necessary to raise brute force samples.
You can also try to clamp the rays, set the max sub sample intensity to 1 (Sample filtering section)
Also avoid to light the volume with mesh lights.

However 8mn for the "simple" scene seems too long for me.
but honestly, it's hard to say what's going on, without looking at the file.
So much interactions between materials, lights, and settings, in your project can lead to these results !

Oh this is really informative I have a backround mesh light (the light coming out of space) with a 50 contribution scale, and a soft lesh shadow on the opposite side (behind the camera at 30 emission) the blue lights across the walls are at 15 and the others are actually low (bolts, scorch and sparks). So yeah. I emitted volumes with mesh lights EVERYWHERE jajaaj. I will have to take a look at the max sub sample intensity to know the math behind of it since I dont know anything about it but overall this is really usefull information

I made the meshlights because im the documentation it said it was faster and cleaner with gi than emissives. I didnt know about volumes though. Experience for later works I gues huh jajaaj

Edit: the volume is not emissive and every light is a mesh light

Edited by pizola
Missing info

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, pizola said:

I made the meshlights because im the documentation it said it was faster and cleaner with gi than emissives

yes meshligths are better than emissive materials but not as real light, especialy when it come to volumes.

All these lights with volume contribution are probably not a good idea.
Try to supress all volumes contribution and try to light your volume with a minimum of area lights to recreate your look.
Then from these lights excude the scene or turn GI contribution to 0.
In short a lighning for the scene and a lightning for the volume.
The goal is to avoid GI interacting between the scene and all these light, with the volume. This kind of advice is from the devs themself.

If you make still images it's not really a problem, but when it come to animation you have to take care how you build your lightning.
Even with redshift :)

 

[edit] Since it seems that all your materials are reflective but higly roughness you can try to reduce the maximum trace depth reflection to 2 even 1

Edited by flcc

Share this post


Link to post
Share on other sites
1 hour ago, flcc said:

yes meshligths are better than emissive materials but not as real light, especialy when it come to volumes.

All these lights with volume contribution are probably not a good idea.
Try to supress all volumes contribution and try to light your volume with a minimum of area lights to recreate your look.
Then from these lights excude the scene or turn GI contribution to 0.
In short a lighning for the scene and a lightning for the volume.
The goal is to avoid GI interacting between the scene and all these light, with the volume. This kind of advice is from the devs themself.

If you make still images it's not really a problem, but when it come to animation you have to take care how you build your lightning.
Even with redshift :)

 

[edit] Since it seems that all your materials are reflective but higly roughness you can try to reduce the maximum trace depth reflection to 2 even 1

Oh, this comes in really handy.

If I understood correctly, I should remove volume contribution from my former lights. The volume will become black so I will have to add new lights to light up the volume and exclude the scene entirely from these so it doesnt add the newer lights. My only questions is: will I have the shadows from the volume casted onto the scene after I excluded it?

So, at the end of the day, GI and volumes hate each other. I will end up having 2 sets of lights. One with Gi for the scene and the others without it (max GI trace depth set to 0?)

you have been really helpful. Thanx a lot :)

Share this post


Link to post
Share on other sites
9 hours ago, pizola said:

will I have the shadows from the volume casted onto the scene after I excluded it?

Unfortunately not.

"So, at the end of the day, GI and volumes hate each other." : It's a bit radical, but yes, that's the point.
Try like this and see if you get any improvement. It'll already give you a clue.
See if this is visualy really different.
If so, maybe you can keep the closest lamps that generate the shadows of the volume in the volume contribution, without forgetting to set their GI Contribution to zero.
It's a bit of a tinkering thing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×