Jump to content
HappehLemons

No GPU Utilization on OpenCL with Viscus fluids?

Recommended Posts

Posted (edited)

Does anyone have insight on what makes or breaks OpenCL? I have a sim with high viscosity (200~2000) and a particle separation of around 0.02, with a scene total of around 600,000 points per frame but I'm not seeing any GPU utilization with OpenCL turned on. I have a GTX1080ti and my whole scene should fit on it. 

 

The only other thing I have going is that i have deforming collisions my scene the with fluid. Is this "too complex" for OpenCL to calculate or something? I just want to make sure I'm using all my resources properly when doing my simulations and in theory this should be a good scene since it's working with viscus FLIPs.

 

Houdini does see my card, and in the about settings in help I see it's listed under OpenCL. 

Edited by HappehLemons

Share this post


Link to post
Share on other sites
Posted (edited)

More than likely, your simulation is too complex to fit inside your graphics card. It doesn't take much to break the 11GB boundary and you're not even getting all that if you are using the same card for display, or have other applications open. One thing that will kill OpenCL is continuous emission into a scene, without a sink to remove anything. Try disabling caching on the dopnetwork, and write the result of your simulation directly to disk. Having to update the viewport every frame also diminishes the gains obtained by OpenCL.

Particle separation alone is not enough to determine the size of your simulation. It is the box size of your domain that is divided by the particle separation that determines ram usage. If your box size grows over time, your memory footprint will grow.

Try looking into the new sparse solver. Even though it is CPU based, in some situations it can outperform OpenCL.

 

 

Edited by Atom

Share this post


Link to post
Share on other sites

I'll try that! Although my scene does have emissions - it's only for a few 100 frames and particles are killed in the by the bounding box. I would be very surprised f this scene didn't fit at 11gb but perhaps I'm underestimating it. 

Share this post


Link to post
Share on other sites
Posted (edited)

still, flip fluids do not gain much with openCL in Houdini18.... i had test in 96GB dual Quadro system, it made 5% difference.

Edited by schwungsau

Share this post


Link to post
Share on other sites

Thanks for the info. I guess I'm more curious on why I get 0 GPU utilization based on my performance monitor, but it's at least good to know i'm not giving up much in case I'm not able to debug this one. 

Share this post


Link to post
Share on other sites
Posted (edited)

The only way I have been able to experience OpenCL speed up is by following the rules listed here:
https://www.sidefx.com/forum/topic/25234/

That post is for smoke, but it applies to flip and other OpenCL accelerations as well.

Turn off the cache, don't continuously emit, and write your result directly to a disk file. Each time you break one of those rules, the CPU comes into play and the GPU advantage drops lower. Updating the viewport every frame pretty much eliminates the OpenCL gains. The most I have been able to get out of flip was about a 35% utilization on my GPU, which I monitored using MSI Afterburner.

Try the example file at the link. It's fun to see how quickly you can simulate smoke  on your GPU.

Edited by Atom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×