Jump to content
anicg

smoke has a hairy look

Recommended Posts

Posted (edited)

Any idea what could be behind the hairy look of the smoke?

When the smoke has just been emitted it looks detailed but overtime it turns into .. a hairy look. I've placed a light behind it so I can see the edges clearly. It has several gasdisturb nodes, no dissipation and no evaporation (both set to 0).

Actually even in the beginning (image 2) there is that hairy look around the edges, so I do not even know if it has to do with age.

 

hair  in smoke.JPG

image 2.JPG

Edited by anicg

Share this post


Link to post
Share on other sites

Too much disturbance probably.

Share this post


Link to post
Share on other sites

I've used 3, here are the attachments, I can keep tweaking but maybe you have an idea from your experience.

 

gasdisturb1.JPG

gasdisturb2.JPG

gasdisturb3.JPG

Share this post


Link to post
Share on other sites

Those disturbance values seem too high for smoke of your scale. I'd personally try to dial them down to the 1-2 strength range. And maybe set the Gas Disturb nodes to disturb your velocity field instead in the Bindings tab, because I feel like this tends to produce more interesting results as the simulation goes on.

Share this post


Link to post
Share on other sites

I've reduced all three gasdisturbs to strength of 1, and the bindings have vel by default as disturb field, but the results still look hairy, like cotton.

Here are 4 renders from 4 different angles (front, back, right, left).

As I mentioned I have dissipation and evaporation at 0.

Do you have any idea why this still looks like cotton / has hairy look

 

111cam4.jpg

111cam2.jpg

111cam3.jpg

111cam4.jpg

gasdisturb1.JPG

gasdisturb2.JPG

gasdisturb3.JPG

bingdings.JPG

Share this post


Link to post
Share on other sites

I think the main problem is that you are adding disturbance everywhere all the time. A popular method is to use the speed of the velocity field as a control field for example, so you scale the disturbance amount with how fast the smoke is moving.

Share this post


Link to post
Share on other sites

I would truly appreciate if you could tell me how I can do that. I do see that velocity is already the disturb field in bindings, do I need to so something else to add disturbance only where the smoke is moving faster?

Share this post


Link to post
Share on other sites
3 hours ago, anicg said:

I would truly appreciate if you could tell me how I can do that. I do see that velocity is already the disturb field in bindings, do I need to so something else to add disturbance only where the smoke is moving faster?

Share a hip file.

Share this post


Link to post
Share on other sites

Here is the hipfile, I kept changing the parameter and tweaking but the result is still the same. I don't know how to use the speed of the velocity field as a control field as user Skybar mentioned above.

hairy_smoke.hiplc

Share this post


Link to post
Share on other sites
Posted (edited)

Check help about Control Field. Right now your Disturb and Turbulence doesn't have influence limit, they apply forces everywhere where density is. Use Control field to limited this, for example by temperature or density.
https://www.sidefx.com/docs/houdini/nodes/dop/gasdisturb.html

Create an explosion or billowy smoke from the shelf and examine what inside.

Edited by fencer

Share this post


Link to post
Share on other sites

I have changed the control field of all three gasdisturbs to use the speed of the velocity, but for some reason the smoke loses its shape at the end (new hipfile included)

hairy_smoke.hiplc

speed.JPG

control field.JPG

d1.JPG

d2.JPG

d3.JPG

frame64.JPG

frame240.JPG

Share this post


Link to post
Share on other sites

Good, right step, you are close.

Use Visualization in gasdisturb to see where forces are still present. Play only with gasdisturb1 first, disable the rest, adjust one than add one more, adjust and so on.

Play with control range, you are adding high values of gasdisturb but trying to limitate only from range 0-1, try 0-5, 0.1-2 or so...

Plus now limit only by velocity, try to add density as well.

 

more_limits.jpg

Share this post


Link to post
Share on other sites

Done simulation 18 times, the problem is still there: the smoke is hairy. I've used the control field with speed, tweaked gasdisturb settings, at different block sizes, different strength, tweaked temperature diffusion, the smoke is still hairy. I've watched countless courses / tutorials, I've even replicated their exact settings, the smoke is still hairy. If I bring down the strength of the gasdisturb the smoke is too smooth in the first 100 frames.

There is something else, I hope someone knows what's going on.

After 18 times, this is what the smoke looks like:

sim18_cam2.jpg

sim18_cam1.jpg

Share this post


Link to post
Share on other sites

That's overcranked disturbance. You could try keyframing it down over the first 30 frames.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

I've keyframed it yesterday several times, the problem is that the newly emitted smoke needs different settings than the older one that's been around for a while, and this is even in later frames because there is still new smoke being emitted, any change to satisfy the old one upsets the new, any that satisfies the new upsets the old.

Edited by anicg

Share this post


Link to post
Share on other sites

Again, check shelf tool "billowy smoke".
You are using very low gas dissipate, smoke almost stay forever, at the same time there are no forces to move this smoke except gasdisturb and turbulence which tearing it apart.
Main motion of smoke is Buoyancy (which based on temperature) or wind, in your case temperature disappears very fast, Buoyancy stop working, smoke not rising anymore but gasdisturb keep working.
Find a good reference and examine real behaviour.

Share this post


Link to post
Share on other sites

How are you rendering the smoke volume? Is your shader doing any displacement or uprezzing of any kind? I could be mistaken but your renders seem to show a level of detail higher than what you would expect to get from the voxel res in your sim....

  • Like 1

Share this post


Link to post
Share on other sites

What are your noise setting in the shader?  Your new 18 sims, renders look as hairy as the old ones....looks like a mad overblown noise in the shader. :P

Its kinda cool for some soft stuff. 

Share this post


Link to post
Share on other sites
Posted (edited)

I have a very simple shader and here are also the mantra settings:

shader.JPG

mantra1.JPG

Edited by anicg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×