Jump to content
Sign in to follow this  

Vellum hair issue on moving geo

Recommended Posts

Hey magicians,

I'm having some issues adding vellum hair to a moving geo. I tried using hair generate, and a for each loop to pin point 0, but for any reason the hairs go crazy.

Simulated mesh also has static points (used point deform), so not sure what is causing this. I also tried scattering points on the animated mesh, but hairgen doesn't work when I select "per point", is this a bug in 18.0.416? I have normals on the points, but nothing appear. I believe I solved similar before using hairgen on scattered points.


I also selected "match animation", when is not selected, hairs fall correctly, but when I try to make follow the moving points, constraints seems to go crazy:


Any thoughts? 


Edited by caskal

Share this post

Link to post
Share on other sites

Hey @Noobini thanks for the hip! didn't know that usefull group expression for pin, will come in handy to avoid that foreach trick.

After some research, found that guidedeform did the trick, otherwise hairs went crazy. 



Share this post

Link to post
Share on other sites

Hi @caskal , I'm struggeling with the same problem, would you mind to share your hipnc?  I can't figure out how you conneced the guide deform and make it work with the vellum simulation.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this