Jump to content
Sign in to follow this  
underscoreus

[SOLVED] Pyro Sparse Solver Freezes advecting fields

Recommended Posts

Hey guys!
I've recently been doing some pyro work with the sparse solver adding pyro to my RBD sim's recently and I have been hitting this issue where if I make my voxel size too small my sim will freeze at some point during the sim. It always seems to freeze during the "advecting fields" step.
Normally I'd chock this up to the machine running out of RAM or even VRAM but checking in on it the RAM never sees more than 50% usage and VRAM never goes up beyond 10-20%. CPU is pinned at 100% on all cores but the sim is not doing anything.

I have not seen any error message in any pop ups or in the terminal either.

Running Houdini 18.0.460 on Ubuntu 18.04.

Anyone out there who has experienced anything like that?
Thanks for the read!

Share this post


Link to post
Share on other sites
1 hour ago, underscoreus said:

Hey guys!
I've recently been doing some pyro work with the sparse solver adding pyro to my RBD sim's recently and I have been hitting this issue where if I make my voxel size too small my sim will freeze at some point during the sim. It always seems to freeze during the "advecting fields" step.
Normally I'd chock this up to the machine running out of RAM or even VRAM but checking in on it the RAM never sees more than 50% usage and VRAM never goes up beyond 10-20%. CPU is pinned at 100% on all cores but the sim is not doing anything.

I have not seen any error message in any pop ups or in the terminal either.

Running Houdini 18.0.460 on Ubuntu 18.04.

Anyone out there who has experienced anything like that?
Thanks for the read!

I sometimes experiment this kind of freeze but mainly when I use pull method on my sources. One thing that works for me is to increase the velocity extrapolation on the solver settings.

I hope this helps you as well!

Alejandro

  • Like 1

Share this post


Link to post
Share on other sites
5 hours ago, Pazuzu said:

I sometimes experiment this kind of freeze but mainly when I use pull method on my sources. One thing that works for me is to increase the velocity extrapolation on the solver settings.

I hope this helps you as well!

Alejandro

Oooooh, very interesting!
I also found that it was an issue with my sourcing a velocity volume. I managed to fix it by simply upresing the velocity sim a little and I did suspect that there was some issue in interpreting from one resolution to another and if the difference became too big is when this would happen.

Thanks for the reply!

Share this post


Link to post
Share on other sites
6 hours ago, Pazuzu said:

I sometimes experiment this kind of freeze but mainly when I use pull method on my sources. One thing that works for me is to increase the velocity extrapolation on the solver settings.

I hope this helps you as well!

Alejandro

On another note, do you think you could tell me where in the solver to find this setting? Can't seem to find it.

Share this post


Link to post
Share on other sites

Nice to hear that is solved! Regards extrapolation, you can increase the padding settings on the solver (resizing tab - padding) to have more container room with extreme velocities.

Cheers!

Alejandro

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×