Jump to content
ThomasEnglish

Redshift Compositing

Recommended Posts

I apologize for my newness to Houdini. 

I am doing a personal project where I take a still from the sports shoots I do and go a bit mental in Houdini + REDSHIFT. 

I cut the image out and hold it to camera as a card. I use the RScolorsplitter to give me an Alpha chanel and mask it in the material tab. However my "card" gets effected by lighting in the scene. I want to light my scene to the card and not have it colourshift about. The material node alone does all sorts to the colourshift of the card. 

I've discovered that pluging in the texturesampler straight into the output redshift material circumventing the RS material node gives me exactly what I want however I now lose the alpha cutting out mask. 

I've started a whole IMG compositing tab and used op:/img/comp1/OUT in my texture sampler to try and get the mask going in the compositing tab but to no avail. This would be an ideal route as I could then do a little bit of tweaking to the image in Houdini. 

Anyone know how I can have my card retain its photoshop fidelity, be unaffected by lighting and focus using redshift in Houdini. 

I don't want to recomposite back out to photoshop unless I really really have to. Melissa_forte.thumb.jpg.7cafcf97fe2d48dc84046eec396e388a.jpg

 

 

Share this post


Link to post
Share on other sites

You can try using light linking method. In your light, your have a tab called "Objects". Got to, Enable Light-Mesh Associations and then choose what objects you want to affect using this light leaving your card unnafected. I think if you use this symbol "^" you remove just the object and leave the rest on . i.e ^mycard. 

 

Does that make sense?

Share this post


Link to post
Share on other sites

If I want it to still light everything apartfrom my card would it be?

 

* ^/obj/mycard 

only this doesn't work. 

Share this post


Link to post
Share on other sites
Quote

I 've discovered that pluging in the texturesampler straight into the output redshift material circumventing the RS material node gives me exactly what I want however I now lose the alpha cutting out mask. 

Try using a sprite after your texture to cut out your card then you don't have to worry about excluding it from lighting because the above technique does not run through any shader.

 

Share this post


Link to post
Share on other sites

I've been trying the RS sprite node but unfortunately I can't seem to make the alpha channel invisible. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×