Jump to content

Recommended Posts

Hey guys,

I'm copying this post from Reddit to get more exposure. Since you guys are pros, maybe you'll know the answer:


 I'm having an issue with my landscape material. I've got an HDA pulling in a landscape with six layers. I've setup each layer as a material function so I can blend each function in a material based on their layer name.

The problem is the material only works with three layers at a time. I can't do more. This is what it looks like with three layers as expected:

r/unrealengine - Landscape Layers Not Blending Correctly

Three layers with blend mode set to Opaque

The shader fails when I plug in more than three. It shades in a tiny square on the terrain (not shown here), the rest of the terrain is the standard checkerboard:

r/unrealengine - Landscape Layers Not Blending Correctly

Six layers fail with blend type set to Opaque


The only way to view all layers is to set Blend Type to Alpha Composite, however I completely lose my directional lighting:

r/unrealengine - Landscape Layers Not Blending Correctly

Six layers with blend type set to Alpha Composite (no directional lighting)


It must be something with my layering weights.. I just can't figure this out for the life of me. Here are my layer settings:

r/unrealengine - Landscape Layers Not Blending Correctly

Layer Blend settings

Let me know if you've run into this issue; I'm sure it's an easy fix.


Thanks guys,



Share this post

Link to post
Share on other sites

Did you try to plug a Constant3Vector into the layer blend? Just to check if that works.
I just tested a heightfield with 6 different masks and it works.

Share this post

Link to post
Share on other sites

So it seems to be working for base color now, but once I apply any other material attribute it won't shade the terrain. I made a low-res terrain to test.



This is the material:



And this is the texture (it's the same default for testing, but it's working for base color):



However, when I apply ANYTHING other than Base Color, the shader fails:





I'm just copying the Quixel default material into the material function for each layer:



Any idea why this is only working with Base Color?

Share this post

Link to post
Share on other sites

I just tried separating each material attribute and combining them individually via layer blend, however this still did not work... Again base color works fine with this method:



I'll keep messing around.

Share this post

Link to post
Share on other sites

Got it working!! So I needed to change the Sampler Source for each texture sampler to: Shared: Wrap. That and using a TenLayerBlend did the trick!



And the texture sample node:


  • Like 2
  • Thanks 1

Share this post

Link to post
Share on other sites

Hello, I am in a similar boat here and see that you used a TenLayerBlend. What are the inputs at the bottom and how did you create them. I understand the material inputs but the bottom ones elude me. It says sample but what is it a sample of? I feel like I am close!!



Edited by darklordstudios

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now