Jump to content
kfu

ACES Rendering output

Recommended Posts

I'm pretty new to this, but is there a way to render out REC709/sRGB images (PNGs) that looks exactly like how it looks in render view? 

I tried render out pngs instead of exr but that looks totally different.  Or you always need to render out exr images and then do the acescg to sRGB thing in other program, Nuke for example? I was using Arnold btw.

Share this post


Link to post
Share on other sites

In COPs you can use the OCIO Transform VOP inside a VOP COP2 Filter to convert images from ACEScg to srgb or rec709. The DMNK tools also provide a couple of convenient HDAs to streamline that: https://github.com/DominikLingenover/DMNK-Tools

As far as external tools, PYCO is very nice: https://mrlixm.github.io/PYCO/standalone/ColorspaceConvert/home/

Edited by DaJuice
  • Thanks 1

Share this post


Link to post
Share on other sites
9 hours ago, DaJuice said:

In COPs you can use the OCIO Transform VOP inside a VOP COP2 Filter to convert images from ACEScg to srgb or rec709. The DMNK tools also provide a couple of convenient HDAs to streamline that: https://github.com/DominikLingenover/DMNK-Tools

As far as external tools, PYCO is very nice: https://mrlixm.github.io/PYCO/standalone/ColorspaceConvert/home/

ah,thanks for these. forgot that I can process images in Houdini lol

Share this post


Link to post
Share on other sites
17 hours ago, DaJuice said:

In COPs you can use the OCIO Transform VOP inside a VOP COP2 Filter to convert images from ACEScg to srgb or rec709. The DMNK tools also provide a couple of convenient HDAs to streamline that: https://github.com/DominikLingenover/DMNK-Tools

As far as external tools, PYCO is very nice: https://mrlixm.github.io/PYCO/standalone/ColorspaceConvert/home/

I tried both in Houdini and the PYCO tool, but the result pngs are always looks a bit white washed than the render view. 

I rendered out exr from Arnold(is this rendered exr image in ACEScg color space?) and then convert from ACEScg to sRGB-liner with 2.2 gamma (in PYCO). Is this correct?

Edited by kfu

Share this post


Link to post
Share on other sites

I tried Nuke with write node color space settings as utility-sRGB-texture, still looks the same a bit white washed than the viewport:(

Share this post


Link to post
Share on other sites
46 minutes ago, AslakKS said:

Should it not be "Output - sRGB" and not "utility-sRGB-texture"?

I tried output_srgb also, close but still different.(or is it just my eye?) :unsure:

Edited by kfu

Share this post


Link to post
Share on other sites

 

2 hours ago, AslakKS said:

Should it not be "Output - sRGB" and not "utility-sRGB-texture"?

I actually found out that opening the png in photoshop or windows photo viewer slightly changed the color saturation , that why I say 'close but different'.

But when I open it in After effect or paint 3d, it looks exactly like how it looks in Nuke viewer.

No idea why this happens.

  • Like 1

Share this post


Link to post
Share on other sites

ACES pipeline is sometimes applying slight tone mapping before the output which they call RRT (Reference Rendering Transform), and then, your output transform sRGB / Rec.709 is applyed. So you can have slightly different outputs if you are using Utility - sRGB - Texture or output_sRGB or Output - sRGB. I don't know exactly all the slight differences between all those transforms but i dont think sRGB - Texture is a usefull transform to export your pictures.

 

On 30/10/2020 at 11:50 PM, kfu said:

I rendered out exr from Arnold(is this rendered exr image in ACEScg color space?) and then convert from ACEScg to sRGB-liner with 2.2 gamma (in PYCO). Is this correct?

This is in the Arnold ROP. You must choose your render color space (Properties > Device > Color management ) and render output (Properties > Output > Color Space) in the Arnold Rop to know which color space is used.
Theoricly if you want to use ACEScg it should be ACES : ACEScg for the render engine and a linear sRGB / ACEScg for the output then you will need to convert this linear ACEScg/sRGB to an sRGB space with an gamma 2.2 or sRGB / Rec.709 transfert function applyed to be able to display the picture on a sRGB Monitor.

If you want some docs about ACES there is this articles which is a good start and the ACEScentral forum :
https://chrisbrejon.com/cg-cinematography/chapter-1-5-academy-color-encoding-system-aces/

https://community.acescentral.com/

 

PS : And Of course you must install OCIO to manage all those color spaces / transform :)

PS2 : If you are using Arnold be sure to convert your tx and houdini color node to the correct space. If you are using ACEScg and you generate TX textures they will have a ACEScg space applyed so you can't use them for sRGB anymore and the opposite is true too. Same thing for color node in houdini, if you enter a (1,0,0) it will be for sRGB so you need to convert your color node to an ACEScg with an OCIO transform other wise you are not sending the correct color to Arnold.

Edited by k2p8

Share this post


Link to post
Share on other sites
2 hours ago, k2p8 said:

Some docs about ACES there is this articles which is a good start and the ACEScentral forum :
https://chrisbrejon.com/cg-cinematography/chapter-1-5-academy-color-encoding-system-aces/

Plus one for this, I just had a course of one week with him in my school about aces and lighting, and the core of his course was really resourceful and we got a ton of information. This guy is amazing !

The best way to use aces in your pipeline is to render in linear, of course your renderview should show your render with an aces lut (in your case an ACES Rec 709 or sRGB), and then in Nuke you import your linear file, make sure your project settings are OCIO / aces.1.x, and to export your file you just need to use a write Node with ACES/Output/Output sRGB or Rec709.

If you have textures or hdri, make sure you convert them to aces because they differ when you will render them !

Good luck with that, it's a huge mess to understand, but it's worth it when you see how it enhances your renders :wub:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×