Jump to content
Sign in to follow this  
hodini

How to accumulate attribute on the array inside dopnet

Recommended Posts

i am working on the firework effect.

i emitted some particle by pop locate and they replicate some particles when dead.

Each original particle has orginal id and the id is inherited to replicated particles.

 

What i want to do is assign the normal vector of Geometry( sphere)  to the velocity of replicated particles

and  adjust them along the each original id. so i decided to iterate over original id with For loop inside popnet.

I made array list of original id and each id inside the array is taken by Find attribute value count

and again loop over with the count of point number that has each id on the array list.

The point number that has certain id is bringing into the list called "plis" but the list is updating and deleting,adding new pointnumber.  It is not accumulating.

 

how can i fix this ? - my array isn't accumulating but adding one point number and updating the others repeatedly.

and  Do i complicate the process to make little bit simple effect ?

gbg.JPG

fga.JPG

fgh.JPG

Share this post


Link to post
Share on other sites

it works ! it is accumulating  but for - loop in the popnet,  is it the best way to do this effect ?

Share this post


Link to post
Share on other sites

Yes its The Best Way ..and Your File Its Just Beautiful ..Like Compositor-Beethoven:rolleyes: You have Done those nodes :ph34r: : thanx for sharing


@hodini Please Just post Your File Because In this Forum Trust me You have Some Ladies And Dudes that Can help You if you Provide Your File ..Its Very Strange to Assume What You have In your Setup :wub:

Edited by Librarian

Share this post


Link to post
Share on other sites
12 hours ago, Librarian said:

Yes its The Best Way ..and Your File Its Just Beautiful ..Like Compositor-Beethoven:rolleyes: You have Done those nodes :ph34r: : thanx for sharing


@hodini Please Just post Your File Because In this Forum Trust me You have Some Ladies And Dudes that Can help You if you Provide Your File ..Its Very Strange to Assume What You have In your Setup :wub:

??? wtf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×