Jump to content
ejr32123

union compressed fluid broken

Recommended Posts

Hello,

I cannot figure out what the problem is. I was rendering this shot and for some reason the water glitched badly on some frames, as seen in the gif. I found out its because the union compressed fluid setting on the particle fluid surface node is randomly not working on some frames. Causing the inside of the flip mesh to freak out on some frames. My second gif is the inside of the mesh. You can see the frame where the union compressed fluid fails. There is extra mesh detail on the inside What is causing the union compressed setting to break randomly on these frames? link to hip- https://drive.google.com/file/d/1yogPTwvo1pDXj5yx7WW_xVHYn64tjqpl/view?usp=sharing

 

 

Share this post


Link to post
Share on other sites

found the problem, its because when you enable union compressed fluid surface, it uses a union operation in a vdb combine with the surface from the compressed cache and the vdb particle fluid. For some reason the surface was too small on some frames and the union operation. failed. A simple vdb reshape sdf with dilation fixed it

 image.thumb.png.42116d0dad63c93cebd56c49fd61a035.png

Edited by ejr32123
  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×