Jump to content
CKormann

Sparse Pyro Source Problem

Recommended Posts

Hello,

I'm trying out the new sparse pyro tools and really like them. However I am stuck at one point: The "pyrotrailsource" that feeds into the volume rasterize attribute node always produces these weird sources. It looks like the source is cut exactly in the middle in a low and high density field.

5ffc2654abcdf_SparsePyroSource.thumb.png.472f493efff27226280a95b625a7febf.png

The screenshot above is straight from the Shelf Tool "Aerial explosion". You can try it out yourself in H18.5.

Sadly, the issue carries over into my custom explosions. This is how a customized source produces uncontrollable results in the combustion: 

Source:

5ffc26681a437_SparsePyro2.thumb.png.20b5c153b24fd61e2c1787c3722e1c0e.png

 

Result:

5ffc265e0033c_SparsePyro3.thumb.png.12675f424b047c215713447b0cc3b7d6.png

 

Note that this issue is not caused by the shelf tool volume rasterize attribute. I created a fresh node: Same problem. I also checked all the particles outputted by the pyrotrailsource, they look fine and consistent.

Any ideas would be much appreciated.

Edited by CKormann

Share this post


Link to post
Share on other sites

#1 should just be a visualization problem. if you rasterize multiple attributes you'll have to tell houdini how to visualize them and it looks a lot like it's also visualizing some vector field (which visually only appears where values are above 0). Use a volumevisualization sop to define the visualization. And/Or a PyroPostProcess after your combustion sim.

#2 can just be the viewport clamping your volume display. hit d in the viewport, navigate to the Texture tab and raise/untick the 3d texture 'limit resolution' parameter. Unless you're worried about the 'naked' flames in which case you can check the @flame value of your source there and adjust the smoke emit range in the pyro solver accordingly.

Edited by nuki

Share this post


Link to post
Share on other sites

did you try Normalize by Clamped Coverage setting on the volume rasterize attributes? that smooths it out. Also it doesn't visualize velocity very well if you are sourcing it. you can add a primitive node and select velocity and go to volume and adjust visualization then hide velocity.

Edited by ejr32123

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×