Jump to content
Sign in to follow this  
Masoud

POP Solver substeps issue...

Recommended Posts

Hello;

For some reason I need to increase "substeps" in a "POP solver", but the problem is it increases the number of generated particles!

How can I fix it?

 

Thanks for helping.

Particle_Substep.jpg

Particle_Substep.hip

Share this post


Link to post
Share on other sites
1 hour ago, Masoud said:

Hello;

For some reason I need to increase "substeps" in a "POP solver", but the problem is it increases the number of generated particles!

How can I fix it?

 

Thanks for helping.

Particle_Substep.hip

Yes, this is how DOP works, each substep all nodes in a dopnetwork cook. As i can see you want particles born just ones, in this case use expression in 'Impulse Activation' parameter:

$ST < ch("../timestep")

It will be independent how much substeps you have.

Share this post


Link to post
Share on other sites

Don't substep the DOPNetwork, substep the PopSolver.

 

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, vicvvsh said:

Yes, this is how DOP works, each substep all nodes in a dopnetwork cook. As i can see you want particles born just ones, in this case use expression in 'Impulse Activation' parameter:


$ST < ch("../timestep")

It will be independent how much substeps you have.

Hi Victor and thanks for your reply,
I changed the "Impulse Activation"  from $F==1  to  $FF==1 ,  and problem solved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×