Jump to content
Sign in to follow this  

Modified principled shader won't export to ifd

Recommended Posts

Hey everyone,

so I've set up a scene with a principled shader and it rendered fine when I exported it to ifds and rendered it on our farm. But then I needed an extra AoV for an attribute to mask out parts of the object that has the shader assigned. In order to get that to render, I opened the principled shader and did a simple bind->bind export setup for that variable which then rendered fine locally. But from then on, no matter what I tried when exporting the scene to ifds, the object with the open principled shader would always render as if it has no material assigned. I tried forcing VEX shader embedding, which made the ifds quite a bit bigger and made me hopeful, but to no avail, all I get is grey shading. For now, I render the mask as a constant material in a separate mantra node but there has to be a way to output an attribute in an AoV when using the premade shaders. Any help is very welcome!.

Thanks in advance,


Share this post

Link to post
Share on other sites

A simple example seems to work for me locally.  You can generate a IFD locally then just call the command-line Mantra on that IFD to test...  that should help narrow down where things are going wrong.

Another debugging tip is to open the IFD in a text editor and double-check you see your modified shader source in there (could be hard to find, but you should be able to just search for the bind export variable name).



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this