Jump to content
guache

Viewport transparency broken?

Recommended Posts

I can't get transparency to look right in the viewport (H18.5). My viewport is set to smooth-shaded. Opaque objects with materials/textures look correct. When I try to display transparency, something is always broken.

If I set "Alpha" on the points and don't use any material, the object's transparency is shown correctly, but the color is black-and-white (as if Alpha replaced the color), ignoring the point color values. The various transparency "quality" settings in Display Options do more or less what you'd expect.

If I set "Alpha" on the points, assign a material ("Use point Alpha" is on) to the object, I get different visual bugs: the object either vanishes, is only shown in outline, or just a tiny part of the object shows. If I un-assign and re-assign the material, or select the object's node (so that it's "highlighted" in the viewport), the object briefly looks right. But moving/panning in the viewport instantly brings the visual bugs back. The "quality" settings in Display Options have no effect, only "Cutout" shows the object (as solid).

The graphics card is Nvidia RTX 2080. Is this purely a Houdini issue or would tweaking some Nvidia's GL settings help?

Edited by guache

Share this post


Link to post
Share on other sites

Same problem here.
Makes it really hard to do proper viewport captures when using transparency.
Sad, but I find myself exporting objects to Blender allot these days.

Nvidia RTX 2080 Super

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×