Jump to content
papsphilip

Subdivision render artifact

Recommended Posts

after the subdivide node you can see these star shaped polygons appear and as a result produce render artifacts.

How can i fix this?

subdivision is not really needed in the center of the circular polygon but mostly on its edges so that they get rounded along with the rim.

 

Capture.JPG

Share this post


Link to post
Share on other sites

As a quick and dirty solution, you can just make a group for the rim geometry and use that to limit what the Subdivide node affects

  • Like 1

Share this post


Link to post
Share on other sites

The star-shaped subdivision is the expected result with your topology. To get rid of the visible shading "artifacts", select the large ngon in the center, append a PolyExtrude SOP and increase the Inset parameter a little bit. Increase the divisions to 2 as well. That will provide a sort of anchor where the sides meets the face and still give you rounding along those edge.

Share this post


Link to post
Share on other sites

thank you! i ended up bricking up the ngon with a divide node and the artifacts are gone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×