Jump to content
Sign in to follow this  
inversionstudio

Redshift Displacement with Instances

Recommended Posts

Hi guys, I'm currently rendering a large amount of assets in a scene which are instances of 4 objects.
When rendering redshift gives me this error:

My object uses adaptive tessellation, which isn't supported. Disabling tessellation. If you need tessellation, please use fixed tessellation settings: i.e. disable 'screen space adaptive' and set 'min edge length' to zero to force a maximum tessellation level

I have adjusted the settings as requested but still my objects are not displacing properly, does anyone have any ideas/solutions to this issue?

Many Thanks

Share this post


Link to post
Share on other sites
Posted (edited)

It's not an error. It's the way redshift works. If you use render instances you must use fixed tesselation setting.

Obviously With massive scenes it can be penalizing. A workaround could be to have two groups of objects. One for the foreground where you keep the displacement, but no screen space adaptative,  and another for the background where you disable the displacement and with which you can use the screen space adaptative.

2 hours ago, inversionstudio said:

I have adjusted the settings as requested but still my objects are not displacing properly, does anyone have any ideas/solutions to this issue?

Difficult to answer without seeing anything

Edited by flcc

Share this post


Link to post
Share on other sites

Thanks for the reply flcc, I do disable 'screen based tessellation' & set edge length to zero as the warning suggests but I still dont get any displacement happening at all.  Is this behavior expected?

 

Share this post


Link to post
Share on other sites
Posted (edited)

It depend on your geometry and the "Maximum subdision" setting.  'min edge length' is a limit to restrain number of polys when subdivision is high.
If your subivision is not sufficient, you may not see the displacement effect.

a "min edge length" at zero don't help in this case.

And by the way, "min edge length" to zero setting, is an advice, but not required.
Basically once screen space adaptive is deactivated, you are on your own to get the best result.

Edited by flcc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×