Jump to content
bentway23

OpenCL Exception: Could not open OpenCL program

Recommended Posts

Hello! I'm trying to use an OpenCL node and the console pope up with the error in the subject line as soon as I click on it. Googling didn't help me--I updated my GPU drivers to no avail. I also added "HOUDINI_OCL_DEVICETYPE=GPU" to my .env file (per another forum), which didn't help. When I open the nVidia control panel to turn on OpenCL, it doesn't appear in any of the device manager settings, just OpenGL (and for the program-specific settings, Houdini doesn't appear at all).

I'm running Windows 10 on a computer with decent horsepower and an RTX 2070 SUPER graphics card, so computer beefiness or up-to-date-ness shouldn't be a problem. I'm also running Houdini Indie (the latest build--18.5.499).

Thanks for any help!

Share this post


Link to post
Share on other sites

@bentway23
Houdini Help Show Panel I have a same Card no problem.

Do you have This???





 

cvvvc.jpg

Share this post


Link to post
Share on other sites

I do indeed, and it appears to match yours exactly (at least, the OpenCL lines do). I'm sure it's just an option I have to check somewhere. (I've noticed all along, both with this and with the previous Houdini build (18.5.408) that I would get an error any time I tried to use OpenCL with a pyro solver, but I didn't think much of it given how lightly I was using pyro. Today was my first time using an OpenCL node. I'm guessing it's just a setting I have to check somewhere.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×