Jump to content
Daniel16_16

Exporting Pyro Simulation as VDB problem

Recommended Posts

Hey all,

I have set up a very big smoke simulation. And now I would want export it as VDB Files which I could import then into Blender. 

So far so good, but when I click in the file cache node on "Save to disk" it starts exporting it, but after like 60 or 70 frames its just stopping and Houdini is closing itself or there were an error which is saying "not enough memory" and some other stuff..... 

But this error isn't truth, because I have a external SSD where are nearly 500GB are left. After 60 frames (its only like 65 GB) its stopping... I dont know the issue but if someone has an idea, why its not exporting the whole frame range but just one part (like, 60 frames of 500 frames). 

It would be awesome if someone could help me... :/ 

My division size is 0.12 I have tried it with 0.09 and it has closed after 50 frames, now I have tried 0,12 and it has closed after 70 frames... I have tried to export it before on 0.2 I think, and It has worked without any problems. But when I like a better resolution then its crashing everytime... 

Share this post


Link to post
Share on other sites

when it says out of memory its talking about ram I believe. Try doing the same process but opening up task manager and see if the ram goes to 100% How much ram does your machine have?

Share this post


Link to post
Share on other sites

It is indeed talking about the memory (RAM).
When caching to disk, make sure that you've turned OFF the checkbox "Cache Simulation" on the DOP Network.
image.png.2ec12cb8b439901634ce73c18fd1802c.png

Otherwise it will keep the previous frames in memory and you'll eventually run out of memory.
And in that case, you would get the error you're getting.
With the checkbox off, Houdini will only keep the previous frame in memory to be able to solve the next.

If it was already off, then you might not have enough memory available for Houdini to solve the single frame.
Solutions in that case:
1. Lower your resolution (increase voxel size)
Or 2. Buy more RAM ;)

P.S.: Your SSD is 'storage', not 'memory'.

Share this post


Link to post
Share on other sites

Another way to control memory usage is to control domain size expansion. Sparse can easily get out of control as it enlarges itself to contain the pyro, consuming more memory by dividing the bounding size by the division value. For example missile trails that shoot off in all direction are a bad idea for a single simulation. Perhaps you need to break yours down into smaller manageable simulations that will fit within your physical memory? Or turn up Dissipation to remove old values from the simulation more quickly..?

Share this post


Link to post
Share on other sites

Also another option to optimize the simulation is this Clamp Below parameter. Any density value below this will be zero and the solver won't care about it, so you can gain a little bit of performance boost. Default value is 0.005, I found it usually unnecessarely low.

image.png.ed319b71cbdc106af677f1b0d78b614b.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×