Jump to content
hyunj16

"Redshift RenderView" result is different than "Render to Disk" result

Recommended Posts

Hi, I have a weird problem with Redshift in Houdini.  I looked for solutions searching on Google but couldn't find it.  I read Redshift documentation with Houdini plug-in and couldn't find it.  If there is anyone who'd know what this problem is and know a solution for it, please help me out.  

So I created this simple scene with a text and a simple glass texture.  I lit it and everything looked fine on Redshift RenderView (See attachment "Capture 1")  I even enabled PostFX using Bloom.  Color management is set to display "ACES" and Red.709 as "View"

However, once I hit "Render To Disk", the MPlay window shows something way different even though it's set as "ACES" and "Red.709" (See attachment "Capture 2") It seems to have a different hue with higher vibrancy.  The bloom is affecting the scene a lot more.  

Once I brought in the rendered exr sequence in After Effects, it looks a lot different than what I saw on MPlay -- which is supposed to be the same file.  (See attachment "Capture 3")  Not to mention, added "Bloom" effect is nowhere to be seen.  

Any Redshift experts out there who can help me out?  Thank you.

Capture1-REDSHIFT_RENDERVIEW.PNG

Capture2-MPLAY_RENDER_TO_DISK_AND_REDSHIFT_RENDERVIEW.PNG

Capture3-RENDER_TO_DISK_BROUGHT_INTO_AFTER_EFFECTS.PNG

Share this post


Link to post
Share on other sites

Hi! I don't use After Effect, but when I load my EXR sequence in DaVinci, the colors are weird too and I need to setup the "Rec 709" option with the calibration part to obtain the "good" colors.

Maybe you have the same problem with AE, you need to precise the ACES options...

Share this post


Link to post
Share on other sites
Posted (edited)

When you bring your sequence in AE right-click on it and hit interpolate footage and in the color management pick ACES
should be ok
you can also download the OpenColorIO plugin for AE and load your OCIO config and you should be good
I'm not sure about the bloom effect, if you're not seeing it in the output might be because you haven't checked the Post Effects option on your Redshift_ROP node but it's probably not that and will be fixed with changing the color management setting.
If you're not getting the result that you want there is also an option for ACES in AE's Project Settings so make sure to check that as well

Edited by armin_lotfi

Share this post


Link to post
Share on other sites

I have been having this same problem for ages. Exactly like Jeong. My renders look like they are in a totally different gamma space to what I see in RenderView

What is even weirder is the render via MPlay they initially render normally and then at the end it just flashes up by a load of gamma or exposure before moving onto the next frame. Off-course the output rendered is this bright version. 

Its annoying because you can colourcorrect it in EXR's but I am trying to do some jpeg renders. There is a redshift setting somewhere that is post modifiying the gamma and yeah I have check all post effects.. bloom etc come on smartly before this exposure jump. 

 

 

Share this post


Link to post
Share on other sites

if you want to render this postfx baked you have to add them postfx you need to have the first boxes checked by default they are not. However, I wouldn't recommend doing this but if you want that there go you.

houdini_nD2gzUCNBT.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×