Jump to content
Sign in to follow this  
CGRowdy

Transform Pieces has unexpected offset after simulation

Recommended Posts

Posted (edited)

I stumbled over a problem with the transform pieces SOP when i use a timeshift between two simulations. 

In my setup i simulate the pieces with a rigidbodysolver, extract the points with dopimport, transfer the pieces onto those points and simulate over the pieces again. And the final step is a transform pieces.

This works fine, as long as there is no timeshift between the two simulations. When i introduce a timeshift, the transform pieces SOP places the pieces nowhere near the extracted points. 

offset.png.2dd7bfb5655be621e810931cd9832a34.pngreorient52.png.59dd2e7ac78f6429f9c4dc565dce997b.pngnodetree.thumb.png.afb776377c3b86604845933772b21516.png

 

 

 

 

nested-sim-timeshift-2.hipnc

Edited by CGRowdy
changed example files

Share this post


Link to post
Share on other sites
Posted (edited)

@Librarian No, the motion from the second simulation is correct. Only the transform pieces in the end doesn't work

Edited by CGRowdy

Share this post


Link to post
Share on other sites

The second time TransformPieces sometimes causes weird instrinsic result.

You may try this.

 

image.thumb.png.10a9a4796c12429630f3bb07359962d6.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×