Jump to content
Sign in to follow this  
archz2

Reducing noise in Redshift?

Recommended Posts

Posted (edited)

I am new to redshift. I am using version 2.6.41. 

If I render the scene with just a sphere and donut, it renders out fine. 

 

6124d0ea2e2d9_redshift1.thumb.png.ece99d748edce4a798798ec7b701e209.png

 

Despite using a number of samples, I am getting noise on the ground when I have the organic blue volume. 

RENDEROUPTUT.thumb.png.72c8df9364795f720bad51b0281828a1.png

RSAMPLING.png.13a48d678792e33e12461570d494bcf9.png

Here is the .obj file which is used in the scene. 
https://www101.zippyshare.com/v/THie8eoD/file.html

 

Here's the hip file. 

RS_RENDER QUERY.hip

 

What should I do to reduce noise? The render time is quite high too at 8 minutes. 

 

I rendered similar geometry (the blue organic geometry is same, only the sphere and torus are different) in Keyshot but the render time is very less. 

 

I tried with 100 samples, 200 samples and 500 samples. 

 

6124d496ba4d9_100samples.thumb.png.5e8c0628736c940227e908ca1a995f15.png

 

 

6124d4bdaa336_200samples.thumb.png.9600e983691639965ee8f4b53435c6b4.png

 

 

6124d4d5e6a82_500samples.thumb.png.796714182d2b4d9d15e09281e90d4122.png

 

Edited by archz2
More images added later

Share this post


Link to post
Share on other sites
Posted (edited)

Hello
I took a look at your scene and I must say that it's a bit weird.
Normally it shouldn't take this long to render.
It seems that redshift doesn't like your organic shape. I've tried different kinds of optimization but nothing really works. I don't know what kind of hardware you have but at home with 2 1080ti the render takes between 45 and 47s which is huge for a scene with 3 objects and one light. The organic form is very heavy but not that heavy, and it doesn't usually affect redshift.
So I exported the scene to C4D where I'm used to rendering. The render goes to 5s, which seems much more reasonable, but... is horribly noisy. This is not the usual behaviour.
I don't have the time to invest any more, right now, but something is not right, not tweaking parameters problem IMHO.

Edited by flcc

Share this post


Link to post
Share on other sites
8 hours ago, flcc said:

Hello
I took a look at your scene and I must say that it's a bit weird.
Normally it shouldn't take this long to render.
It seems that redshift doesn't like your organic shape. I've tried different kinds of optimization but nothing really works. I don't know what kind of hardware you have but at home with 2 1080ti the render takes between 45 and 47s which is huge for a scene with 3 objects and one light. The organic form is very heavy but not that heavy, and it doesn't usually affect redshift.
So I exported the scene to C4D where I'm used to rendering. The render goes to 5s, which seems much more reasonable, but... is horribly noisy. This is not the usual behaviour.
I don't have the time to invest any more, right now, but something is not right, not tweaking parameters problem IMHO.

Thanks for taking a look. I have intel i7-8750H processor, Nvidia 1050Ti GTX 4GB graphics, 16GB RAM. This is weirder than expected. How much samples are you using in C4D ?

 

 

Share this post


Link to post
Share on other sites

I use 32 sample, all other parmater by default. For a simple scene like it could be enough, but as I said the result is VERY noisy. This is what is weird.

I'll have another look tonight as it tickles me.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Funny how sometime you can bang your head for some time on an otherwise simple problem.
As I say I usually make renderings with C4D.
For test i had created a new Rop and Disable your, with the yellow tag. But this don't work. You MUST choose the ROP from the renderview. That's why I couldn't reduce the calculation time in Houdini.
I learn something today ahah.

Now the main problem was the lighting conditions. Lighting a scene with a single strong light that will generate all the light bounces is a bad idea. The result is that as there are not enough rays (the more indirect the lighting, the less rays), noise appears, which encourages to increase the overall number of samples. But in general this doesn't solve the problem unless you go very high and increase the computation time.
This is also why the blue object increases the noise. The light is just above the hole and captures part of the rays. Some of them come out but in small numbers and generate noise.
I invite you to have a look at the doc in the sampling section, it's really well explained.

The example of keyshot, that you show, illustrates this. This a totally different lighning. Since this time there is a dome light that illuminates the scene (many rays everywhere) everything is fine.
That's why I added a simple white dome in the scene. I also disabled affect specular in the ray section so as not to get the nasty white reflections.
The renderings run for 9s which is reasonable (Not noise free though).

On the other hand if you want noise free renders it's better to use irradiance point cloud in second GI engine.
If you really want it to be super clean the Optix denoiser works pretty well.

RS_RENDER QUERY F.hip

Edited by flcc

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks a lot. Sharing what I'm experiencing. 

 

This one rendered in 1 minute 5 seconds without denoiser turned on . 

 

61273cc41025d_1M5WITHOUTDENOISING.thumb.png.2e45f88ac0622a88e8747c106cf5d630.png

 

 

This one rendered in 1m 34 seconds with Optix denoiser turned on. While there is considerably less noise on the ground plane, the noise on the blue surface increases significantly. 

 

1M34.thumb.png.a7dc0a64aafd9bcf369e959f663af58a.png

 

 

8 hours ago, flcc said:

I also disabled affect specular in the ray section so as not to get the nasty white reflections.

I am unable to find this setting. Where is it?

 

Moreover, is there any way to see a progress/percentage based timer going on while the render is happening like the one seen in Keyshot at the bottom right?

 

Also, when I opened your file, I got this error. Why is that?

 

ERROR1.thumb.png.a3a7cdc0d40389c92b45fa0b85f07157.png

Edited by archz2

Share this post


Link to post
Share on other sites
Posted (edited)

"the noise on the blue surface increases significantly.  "
I'm not an expert with optix, but denoising (noy specifically optix) can fail in some situations, when the noise is not "reconized". Probably what's happen here.

"Also, when I opened your file, I got this error. Why is that? "
We don't use the same version of redshift, but this should not be a problem.

"I am unable to find this setting. Where is it?"

Capture.JPG.eeaf707cf4c15655e2daad0dea160556.JPG

 

"Moreover, is there any way to see a progress/percentage based timer going on while the render"

Normaly at the bootom right of the render view you should see a progress bar. Maybe due to the old redshift version ?
Houdini and redshift versions are pretty "linked".

 

Edited by flcc
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Okay. Thanks. 

 

 

 

2 hours ago, flcc said:

Normaly at the bootom right of the render view you should see a progress bar. Maybe due to the old redshift version ?

Yes. Sometimes the yellow progress bar shows up, sometimes it doesn't. I don't know why. 

 

Another question. I was wondering why you setup redshift in c4d for all your scenes. Is setting up Redshift in Cinema 4D better than in Houdini?

Edited by archz2

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, flcc said:

I'm not an expert with optix, but denoising (noy specifically optix) can fail in some situations, when the noise is not "reconized". Probably what's happen here.

 

So what is your workaround for reducing/eliminating noise in renders? I'm getting noise in a scene that just contains 3 objects and only two plain textures. I'm unable to figure out how things will go when I will have more objects in my scene. 

Edited by archz2

Share this post


Link to post
Share on other sites
Posted (edited)

It's not that the renders are better or faster in C4d it's that the integration is better. I find redshift in houdini a bit clunky. Just one example, in Houini/Redshift you often have to refresh manually. The result is that sometimes you don't know, if your settings have no effect or if it's redshift that doesn't refresh. Annoying and never happen in C4d.
And simply put, I'm more comfortable in C4d.


"So what is your workaround for reducing/eliminating noise in renders?... "
As i said noise come from lighning condition, and also reflection and reflexions, not number of objects.
An exterior scene with a domelight, even if your scene is very heavy, will not be a problem. In contrast, an interior scene with just some objects can be very hard to get clean.
In bulk :
If a reflexion generate noise you can up the sample at material level.
Sometimes you have to look for things that can generate noise: for example, reflective walls when it is not necessary.
Light the scene sufficiently even if it means darkening it afterwards in post production.
All tips are welcome. I do a lot of post production work behind the scenes. I aslo use redgiant denoiser sometime (less now).
There is many way to make optimsation in redshift, but really light is the key.
And I highly recommand you to read the sample section of the redshift Doc. Very instructive.

Oh, and we probably don't have the same quality criteria.
As I only do animation, often in very short delays, a bit of noise here and there doesn't bother me.
 

Edited by flcc
  • Like 1

Share this post


Link to post
Share on other sites

Okay. I'll experiment more with dome lights and increasing material samples. 

 

On 8/27/2021 at 2:20 AM, flcc said:

reflection and reflexions

What exactly is a reflexion?

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry, typo error, I mean reflections and refractions.

(reflexion is french word for reflection)

Edited by flcc
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×