Jump to content

[SOLVED] Fighting to get Renderman to work in new machine.

Recommended Posts

Renderman (23.5, 24.0) has been running fine on the laptop in Pop!_OS!:

Recently got a new desktop machine. Installed Houdini (Python2) and Renderman(24.1) on both Pop!_OS and Fedora systems, but whenever attempting to Render Preview in either or use the IPR Tool I always get this error with any version(18.351, 18.596) and don't know how to debug it.

"RfH: Could not initialize Renderman"
"Failed to save output to file"
"AttributeError: 'NoneType' object has no attribute 'warn_if_no_access"


I'm wondering if it's an hardware issue or some missing lib, because either environment variable or json package was working on the laptop with the appropriate versions.
I've seen threads where people mention non-latin characters in the user name but I've tried with "user_01" and now "admin" and the errors the same.

Has anyone faced and fixed this before? It's giving me a hard time.

Test scene file I'm using: rmanQA.hiplc


Edited by probiner

Share this post

Link to post
Share on other sites

Thank you to @master2045 on Renderman discord for the pointer about the missing library libtinfo5, which is fixed in Fedora by installing the ncurses-compat-libs  package.
Only I've seen this mentioned around the web, was here: https://www.carlocarfora.co.uk/blog/2019-12-16_Installing-Fedora-Houdini-and-Renderman/2019-12-16_Installing-Fedora-Houdini-and-Renderman.html

Finally! :)

I never had this issue before in Pop!_OS, but to fix it there just search the library libtinfo5 in the Synaptic Package Manager.


Finally 2.0! :)

Edited by probiner

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now