Jump to content

Recommended Posts

Hello,

I have a massive smoke simulation going on, and now I want to export this simulation in vdb's, to import them into a another 3d software (Blender). 

But when I click on the cache button or render to disk button, everything goes well, until frame 70 +-10 frames or so.. and then it stops because I am getting out or RAM. As I have 64 GB RAM, I would love if someone could explain me, how can I export the whole simulation, without decreasing the smoke division size... or smoke quality!

I have tried to just export the density field, but then the smoke looks kinda low res and only if I am exporting ALL pyro fields, like: density, temperature, fuel, vel x, vel z, vel y.... and so on, then the smoke is high-res in Blender. 

But if I am exporting all fields, then it stops after frame 70 because of the RAM... 

is it possible to cut this simulation in parts and exporting them seperatly or somehow optimizing the fields or the pyro sim or vdb's so that I can export the whole simulation without any problems AND in high-res quality?


Thanks for advance

Daniel 

Share this post


Link to post
Share on other sites

My guess is that your simulation continuously expands. That means you will always run out of ram. Disable the continuous expansion of the domain and lock down the domain size. This will result in clipping near the edges where density meets the borders. Consider increasing dissipation to remove density before the smoke reaches those edges. I don't think Blender supports motion blur for volumes yet IDK, so you may not need to write vel.x, vel.y, and vel.z to disk. Save some file size and turn them off during final export.

 

Or kick out .sim files first, and try continuing the simulation a frame before the crash.

Edited by Atom

Share this post


Link to post
Share on other sites

But how do I turn off the "continuous expansion of the domain and lock down the domain size"?

 

Share this post


Link to post
Share on other sites

On the Smoke Object node, disable sparse solving, and enable max size.

If you're using an older DOPs system, disable the Gas Resize Fluid Dynamic node.

Share this post


Link to post
Share on other sites

Uhm what? 

I have disabled the " Gas Resize Fluid Dynamic node" and now the smoke sim is cutted off by the bounding box... 
and also, I dont used sparse solver...

Share this post


Link to post
Share on other sites

Yes, as @Atom noted, disabling the auto-resize would cause your volume to start clipping - review his advice on increasing dissipation to help contain it within locked bounds.

With regards to the number of exports you are wanting, take a closer look at how many you actually need in Blender, Velocity in particular - what field(s) is Blender actually using for the high-res result you want, and are you judging that on what you see in the Blender viewport, or an actual render?  Remove anything you don't actually require for the final result in Blender rather than exporting everything and cut down on the overhead.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×