Jump to content
Sign in to follow this  
dannyreb

POP Replicate particles affect motion of source particles and POP Interact even though they're in a different particle stream

Recommended Posts

I'm working on a POP simulation for a rainy window and I've set up the simulation so that source particles (in yellow) fall with erratic motion due to a varying POP Wind force and Gravity force, emitting a stream of particles behind them (in green) as they fall using POP replicate. The emitted particles are stopped immediately after emission (using the stopped attribute in a POP wrangle). The issue is that as soon as the POP replicate is activated (at frame 200 in the video), the erratic motion of the source particles is lost and they travel more slowly in straight diagonal lines (as the trails of the emitted particles show). I believe that the POP interact node is causing this as the source particles are being attracted to the stationary emitted particles, slowing them down. But what I don't understand is that the POP interact and replicate are in separate particle streams so the emitted particles shouldn't have any effect on the source particles. I've attached a hip file along with a video illustrating the change in motion when POP Replicate is activated. Any help would be much appreciated as I'm pretty stuck on this! Thanks :) 

 

Houdini_POP_Replicate_Question.mp4

POP Replicate Issue.hip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×