Jump to content
Sign in to follow this  
archz2

Very slow redshift render

Recommended Posts

I am new to Redshift. For a very basic scene with three objects, at a resolution of 1280x720, it took 13 minutes to render. I have intel core-i7-8750H, Nvidia GTX1050ti -4GB and 16GB of RAM.

This is the output.

616d2a92588cb_RENDERSAMPLE.thumb.jpg.ba94db0ae26f1be99a3893f2a90cc2b4.jpg

I have rendered more complex scenes in Keyshot at a resolution of 1350x1350 and it takes 6 minutes max for them on my machine. Please suggest a solution.

Here's the houdini file.

REDSHIFT ISSUE.hip

 

 

Share this post


Link to post
Share on other sites

Strange, here it took 7s with 2x1080ti.

According to octane bench 1080ti have a score of 185 and 1050ti 48
2x185/48= 7.7.
Theorically your render should be 7 x 7.7 = (aproximatively) 53s
it is obvious that there is something wrong, Hardware ? driver ? other ?
 

Share this post


Link to post
Share on other sites

Yeah. It's very frustrating to see this. Later on I enabled Altus denoiser dual pass and the render took freaking more than 1 hour to render.

image.thumb.png.5d3d1b478d7c2af67e11b2a4bba72720.png

 

Here are the denoising settings. 

image.thumb.png.23de0da7f0eba1e4769f0e096086106a.png

 

 

Here's the Hip file. 

redshift-issue_1hour-render.hip

 

The hardware that I'm using is already mentioned in the original post. Houdini is installed on Samsung Evo 970 NVMe SSD. It has 30Gb free out of 231 GB. 

I'm using the latest studio driver for my graphics card. 

image.png.2a1badd1b2e55b20cbe890fbd04387d3.png

 

My windows is up to date. 

Share this post


Link to post
Share on other sites

There is clearly something wrong. You probably better to ask on Reshift forum as this is not a Houdini problem or even Redhift himself.

Rather a configuration - compatibity - hardware. I can't really say.

May be reading the redshift log they can find some clue.

  • Like 1

Share this post


Link to post
Share on other sites

I get a 9 second render out of your scene using dual 1070gtx.

Here's what I did. I threw away your ROPs, dropped down a new one, and set reasonable sample values.

I don't see a lot of noise in the scene, but you could improve it further by cranking up the sample values.

untitled-1.jpg

ap_redshift-issue_1hour-render.hiplc

  • Like 1

Share this post


Link to post
Share on other sites
27 minutes ago, Atom said:

I get a 9 second render out of your scene using dual 1070gtx.

Here's what I did. I threw away your ROPs, dropped down a new one, and set reasonable sample values.

I don't see a lot of noise in the scene, but you could improve it further by cranking up the sample values.

untitled-1.jpg

ap_redshift-issue_1hour-render.hiplc

Awesome! Thank you so much!
 

It took 43 seconds now! You're talking about these sampling settings right? You changed only these or something else too?

image.thumb.png.984977c32827074c78adf2c5527459ee.png

 

I did another render using the same file as yours and turned on the Optix denoiser. It got rendered in 1 min 18 secs.! How to decide whether Optix should be used or samples should be increased? By trial and error?

 

image.thumb.png.053cab2a26fb45894c5457f764ebcab8.png

Share this post


Link to post
Share on other sites
1 hour ago, flcc said:

There is clearly something wrong. You probably better to ask on Reshift forum as this is not a Houdini problem or even Redhift himself.

Rather a configuration - compatibity - hardware. I can't really say.

May be reading the redshift log they can find some clue.

Actually I posted there too. A maxon employee is saying that my hardware is not compatible which I find bit weird. All the requirements are being fulfilled by my hardware except the VRAM is 4GB instead of GB.

https://redshift.maxon.net/topic/39413/very-slow-and-noisy-render-with-very-less-geometry/11

If other rendering engines like V-Ray, Twinmotion, Keyshot and Lumion are compatible with my machine, how can Redshift be incompatible?

 

Share this post


Link to post
Share on other sites

I try your second file (the two rops), and the atom one.

Rop1 30s, Rop2 7s, Atom file 8s.

The parameter who slow down the render is the adaptative error threshold. In Rop1 it is 0.001 which is a very high setting.
put 0.01 (the default) and render immediatly down to 7s. And you don't notice any visual différence.
As I understood you use version 2.6.41. This can be a problem, because it's a pretty old version and Redhsift version are pretty linked to houdini versions.
And by theway this parameter has changed, since v3.

 

Honnestly you don't have too much parameter to tweak in the redhift ROP. Default settings are ok for most of the cases.
Just the "max Samples", 64 128 or 256 can be ok.
If you have to go up you have to fond what cause the noise. Frequently reflexion or refractions. At this point you can look at sample setting in the materials.

But I highly recommand you check the documentation about sampling. Really well explained.

Edited by flcc
  • Like 1

Share this post


Link to post
Share on other sites

@archz2: The number of samples you need depends upon the materials in your scene. Read up on the various type of materials and what samples are needed to effectively render them. I only cranked up the Unified Samples because of the Coffee material in the scene. Denoising is always the last option for me, because it blurs the image. Your graphics card is weak, but it shouldn't stop you from playing around with test renders to learn the system.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks a lot Flcc and Atom. I'll definitely dig deeper in the sampling documentation. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×