Jump to content
Pj20

Houdini Alembic exporting without UV

Recommended Posts

So i have a very simple destruction sim and i am trying to take it to maya. I had got the obj from maya with the uv. Now when i go to export the alembic sim, the uv doesnt show in maya. Even in houdini i have to unpack the alembic file to see the uv. Could someone help me with this?

brick_wall.obj

brick.hip

photo-1495578942200-c5f5d2137def.jpg

Share this post


Link to post
Share on other sites

or probably a better way to transfer my destruction from houdini to maya?

Share this post


Link to post
Share on other sites

Thanks a ton! Thats exactly what i want but even now when i import the abc file into maya ( standard import alembic) i am getting a geo with broken uv(no uv). What am i doing wrong? I took your file and saved to disk 120 frames and imported that only to maya.;( Thanks for the help !!

Screenshot 2021-10-19 001028.jpg

Share this post


Link to post
Share on other sites

Maya version? 
Also what rendering are you trying to use out of curiosity? 

Share this post


Link to post
Share on other sites

Maya 19.3.1

Have not rendered it. This is just out of the viewport. and in the uv editor no uvs are there

But i have arnold and maya software to render it

bricktry.mb

Edited by Pj20

Share this post


Link to post
Share on other sites

Im on Maya 2022.2 and is working fine. So it could be a bug in 2019? but I doubt it.
Another way that you can try is through the BF graph which wit will read the alembic way faster plus attributes. Make sure to download the latest BF 2.3.01

https://area.autodesk.com/bifrost/downloads/?_ga=2.135635638.648822367.1633307953-1639519218.1607981494

 

 

uvRbd_graph.ma

4wWVxudEX2.gif

Share this post


Link to post
Share on other sites

Cool thanks ill try it out here in the bf graph and also on another version of maya. 

Also here is the alembic file and maya import settings just to make sure that there is nothing wrong with that.

Download link for alembic https://sendgb.com/u8z6rmIBA9G

Screenshot 2021-10-19 005625.jpg

Share this post


Link to post
Share on other sites

Yeah, same options, if I try to load the .abc from you it doesn't work on the vanilla ABC, but in the BF graph, it works just fine.

Share this post


Link to post
Share on other sites

Could you pls guide me on how to import it and make it work with the bf graph? :)

cant seem to figure out how to import it with that

Share this post


Link to post
Share on other sites

Like this. Make sure you have the Bifrost load in the plugin manager

oICqId9nUG.gif

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×