Jump to content
ejr32123

mega scan renders always look bad

Recommended Posts

hello. I recently started using more of quixel's megascan library with redshift in houdini. Most of the 3d assets render fine, but I seem to have the most trouble with getting textures to look decent, especially grass. I can get dirt looking good, but it seems like I have to constantly change settings like displacement amount depending on the shot angle/lighting. I swear it seems impossible that the render they show was actually made from the same textures. Look at their render of the grass, then look at mine. It's like their are gaps of shapeless color between patches of grass. It looks nothing like the fully dense grass render they have. I tried using both mantra and redshift, nothing comes close to making the grass look anything like the render they have. It just looks flat with gaps between patches of grass.
any tips?

image.thumb.png.21fd4ebe9c11a1e07c2f5df799a254c1.png

image.thumb.png.ac4681ebde97d34ba5cf73a771e66876.png

Share this post


Link to post
Share on other sites

well, I actually found the answer to my question by editing the material in mixer. I think the problem is quixel materials are meant for games, so they include a "occlusion" texture. If I disable it, it looks like my render. Of course there is no way to plug in a occlusion texture into a rs material or principled shader. So what exactly am I supposed to do to get this looking good in houdini?

image.png.71b44e648b7bc6febad3eca1ebaaaa0d.png

image.thumb.png.dfc6740c3c2ac00671fc308e61cb88ae.png

Share this post


Link to post
Share on other sites

update: someone pointed out to me that you can just multiply your albedo by the occlusion. You could do that either in the material or in photo shop/after effects layer the occlusion pass on top and set it to multiply. Then it looks correct.

Share this post


Link to post
Share on other sites

Or use a multiply node and two RSTexture nodes inside the material blender. I'll often tint my AO passes with a solid color using this technique.

Edited by Atom
  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Atom said:

Or use a multiply node and two RSTexture nodes inside the material blender. I'll often tint my AO passes with a solid color using this technique.

that is what I wound up doing. I stupidly put a rs multiply node, then it came out gray. After a few mins I realized it needed a rs multiply vector, lol. I forgot sometimes rs nodes split things like that up.

Share this post


Link to post
Share on other sites

or you can just plug your AO texture in the diffuse weight input.

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×