Jump to content
Sign in to follow this  
edversicherung

How to prevent Vellum constrains from relaxing/switching to their initial state

Recommended Posts

hello friends!

I am trying to set up a vellum sim with some rubber bands shrinking and squeezing a ballon object.
Everything is set up and works okay but after the rubber bands shrinked and squeezed in the object they go back to their original state. i want them to stay permanently in the shrinked form so the mesh keeps squeezed in...

i guess you have to use a Vellum Constraint Properties node in the vellum solver but i could not get it to work..
or is it better to set it up in a dop network....

Inflate.hiplc

Share this post


Link to post
Share on other sites

Depends on how much you want them to shrink. You didn't include the original geo for the balloon, so it was hard to troubleshoot exactly, but hopefully the tube I used is similar.

I think your original remesh of the torus was too detailed. It created a very dense mesh. So even though you were setting the rest length to 0.3, it didn't allow the torus to shrink very much. I got rid of the remesh, made the torus a bit more corase, reduced the rest length to 0.1, and added a bit of dampening to remove some of the high energy bounce to the shrinking.

I also upped the substeps from 2 to 5. It's also possible you just didn't have enough substeps for the solver to converge properly.

If you want them to shrink even more, I might try a different set up for the rubber bands, where you scale them down into position to get your starting shape (you could do this is a drape node before the solver) before running the full sim.

Inflate_V2.hipnc

 

Inflate.hipnc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×