Jump to content
Daniel_Voloshkevych

driven smoke simulation with particles dont collide with the geometry

Recommended Posts

Hey folks

I have set up a particle simulation where I have then attached a pyro sim to it (through the rasterize attributes volumes node)... Also I have imported a few objects where the smoke sim should interact with...

Everything is fine, until one point:

When I am wanting that the pyro sim should collide with the object (seen on the screenshot), then the smoke is just going through the "wall of dirt" (its just a wall with some grass and dirt... ) I just need the collisions so that I can then export the smoke simulation as a vdb sequence... 

What I have tried so far: 

- I have give it more thickness with poly extrude node (also added the collision guide thing to look if everything is fine)
- also I have increased the substeps on the smoke sim
- I have add a object merge node in the pyroFX node (as seen in the screenshot) - just ignore this one node where I have add the red line...
 

But everything I've tried so far, I got no luck to fix it.. :(

 

Pyro problem collision.jpg

collision guide.jpg

Share this post


Link to post
Share on other sites

Did i get your problem right? You wanted the collision to happen properly ?

Also according to the what you have sent ,entire thing was used as source  and when you are importing dop fields , dop node should be the object instead of the entire network .So i fixed it .

I put a regular pyro from scratch and piped your colliison geo into it .It seemed like it worked if i understood your problem right?

 

tank.farm.hipnc

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×