Jump to content
Gianni333

How to avoid stepping/banding in dense volumes?

Recommended Posts

Hi guys,

 

I have an issue with visible banding artifacts both in a pyro sim and in a volume generated from polygons with iso offset.

The artifacts appear as soon as I crank up the density.  The source geo for the static volume is the same as the collider geo for the pyro sim, everything is at the same (high) voxel resolution and from the same highres poygon base geo.

 

Does anybody here know this issue?

 

1.png.4b5781830adba2cefd87e4e51616a352.png3.png.a79bf85757a81dbd5aefcaa159022801.png2.png.384dd1b1cdc25c43ca46df76abd2d1a6.png

 

Share this post


Link to post
Share on other sites

If anybody else runs into this, I didn't find the best answer, but a workaround that worked in that case was to extrude the original collision mesh outwards, make it a volume and substract this from the smoke volume.

Share this post


Link to post
Share on other sites
Posted (edited)

May be you better to post a file.
Stepping when cranking density on volume doesn't seem strange, and probably I don't have enough knowledge (don't really use pyro) but from the pictures I am not able to say much.

Edited by flcc

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×