Jump to content
Sign in to follow this  
jamesearnest244

Voronoi Messes Up Normals

Recommended Posts

Posted (edited)

Hi,

I have a model that renders fine unfractured, but once I've fractured it, I get shading artifcats from bad normals. It looks like Houdini is inferring normals for the new vertices by interpolating between neighboring ones, but it's not looking right. I've tried using an Attribute Transfer SOP to take the normals from the pre-fractured model, and it helps a little but doesn't solve it completely. Also tried the cupsing settings on the Facet SOP and Vertex SOP. I'm stuck. Does anyone have an idea how to fix this?

I'm not doing any fancy fracturing, just the RBD Material Fracture node.

 

Thanks!

Fractured.png

Edited by jamesearnest244

Share this post


Link to post
Share on other sites

I would try and do the fracturing myself, either using boolean fracturing or Voronoi fracture and see if it helps. The RBD Material Fracture is a high-level node that does many different operations inside, but your geo might be a bit special, so it won't work in your specific case. Voronoi Fracture and Boolean fracture do have some options regarding the treatment of normals. 

Alternatively, you can try creating new normals for the geo before fracturing, maybe those new normals are in a better spot for RBD Material Fracture to work straight out of the box.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×