Jump to content
justinngjw

Flip narrow band doesn't work with reseeding/ reseeding messes up retime

Recommended Posts

Hey there,

I'm trying to do some slow-motion with my flip sim and realize that reseed particles are messing up the retime due to its nature to generate new particles every few frames. However I cannot disable reseeding because i'm siming my flip with Narrow Band. is there a way to tackle this without disabling Narrow Band or is there a way to somehow set a fix number of particles and set-id so the sim won't get  mess up when im trying to retime it? 

Share this post


Link to post
Share on other sites

Enable add id in flip solver on particles motion tab. And use id attribute with retime

Share this post


Link to post
Share on other sites
Posted (edited)
17 hours ago, tamagochy said:

Enable add id in flip solver on particles motion tab. And use id attribute with retime

Hey! yes I’ve did that, but the problem is because reseeding are enable, it causes the point and id to shift regularly.

 

this problem can be fix by turning off reseeding, but narrow band doesn't allow me to disable reseeding.

Edited by justinngjw
a more detail reply

Share this post


Link to post
Share on other sites
9 hours ago, justinngjw said:

yes I’ve did that, but it due to reseeding the points and it’s id still changes 

or post your file of simple version?

Share this post


Link to post
Share on other sites

you almost got the way, just try setting "birth threshold" to 0 on flip solver

NarrowBand_Reseed_fix_od.hipnc

sometimes this kind of issues are knotty, generally we can adjust reseeding paramaters,
some lower birth thresholds, higher death thresholds, and lower surface oversamplings, or other parameters, depends on your effect needs
and also, increasing flip resolution is important for decreasing the popping effects

Share this post


Link to post
Share on other sites
2 hours ago, Benyee said:

you almost got the way, just try setting "birth threshold" to 0 on flip solver

NarrowBand_Reseed_fix_od.hipnc

sometimes this kind of issues are knotty, generally we can adjust reseeding paramaters,
some lower birth thresholds, higher death thresholds, and lower surface oversamplings, or other parameters, depends on your effect needs
and also, increasing flip resolution is important for decreasing the popping effects

hey, thanks for the suggestion! however it doesn't seems to work. if you look at the geometry spreadsheet, the id and ptnum are still shifting along with the frame moving forward. 

 

From the file you give, after retime, the particles are still shifting. you can see the first shifting in frame 33

 

I need the particle id to stay the same throughout the sim.

 

I've tried to revisit the parameters as you suggest, but I still can't find anything affecting the reseed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×