Jump to content
Max Schwugier

spline orientation after vellum simulation

Recommended Posts

Hello Guys, 

I am looking for a way to fix the orientation on the points after a vellum simulation on a spline. I want to create a rope simulation and afterwards use the sweep node to get some geo around my spline but it turns out there are some weird twists. (check pictures below)

Ill attach the scene file below. (rope_simulation.zip)

any help is highly appreciated.

 

thank you guys so much in advance.

 

simulated.thumb.png.63a276eb23fd0f93614e55e9a4f10688.pngweird_spin.thumb.png.d96508b8f4ee36fb2a59fb07f19d29ad.png

orient.thumb.png.a514c9d67550f0ae79518a6699474b76.png

rope_simulation.zip

Share this post


Link to post
Share on other sites
On 2022/6/16 at 10:56 PM, Max Schwugier said:

I want to create a rope simulation and afterwards use the sweep node to get some geo around my spline but it turns out there are some weird twists. (check pictures below)

why didn't you use the "orienta longcurve1" node,you got it

rope_simulation_02_final_fix_od.hiplc

Share this post


Link to post
Share on other sites
19 hours ago, Benyee said:

 

thank you guys. In my case the orient along curve + sweep worked but i needed to export geo on alembic into c4d. the more elegant way were exporting a spline and using a spline wrap or sweep inside of c4d but then UVs etc are shifting. Imo its a C4D Problem instead of houdini. It seems like c4d cannot read the orient attribute from a spline.

thank you guys for your help, i highly appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×