Jump to content
archz2

Unable to select items for 'heat within object'

Recommended Posts

I have an AutoDOP Network that I am trying to select for 'heat within object' feature. No matter how much I try to click and select, drag a window around it, it doesn't get selected. What should I do?

 

Sharing a screenrecording of what I face.

 

selection issue.hip

Share this post


Link to post
Share on other sites

The 'Heat within object' tool expects 2 inputs in order work, an object to be used as the heat source and a fluid object (particles) to heat when interacting with the heat source/object. You can see when you click on the tool houdini will prompt you to select an object first (see image), in your case I assume you want the sphere to be the source of heat so select that and press enter. It will then ask you to choose the fluid object/particles to heat, go into your AutoDOP and select the fluid object node and press enter. It should then hopefully work! 

 

P.S. In your hip file you have the 'Viewport Selecting Enabled' option toggled off for the sphere object (under 'Misc' tab), enable that back so the sphere can be selected by the shelf tool.

 

image.png.f54775ad8bf867f8bd83628ce25ccd16.png

Share this post


Link to post
Share on other sites

Wonderful! Thank you so much! I have some more questions. What exactly is this outer huge bounding box and how can I temporarily disable the preview of it? When I press 'F', I get zoomed out a lot and have to zoom in back again. 

 

 

 

image.thumb.png.74c33584da183dbd5aae485ebb38c67a.png

 

Also, how can I disable the preview of the particles while being inside the dop network? I want to remain inside the dop network and play with the parameters in order to see the final result of the melting cube. 

 

If I toggle on the preview of my object 'box_object1_fluid', it overlays with the particles also. Even though I have toggled the 'hidden' mode of the output node, I still see the particles. 

 

image.thumb.png.dea70d28814ad4bafc71987ee3912af0.png

 

Share this post


Link to post
Share on other sites

The purple box represents the bounds of the simulation, anything inside that box is what gets simulated. Go the flipsolver node and under the 'Volume Motion' tab open the 'Volume Limit' tab, from there you can toggle off the preview of the box as well as control the sizing. You can also use this bounding box as a collider, click on the fluid object node and toggle 'Closed Boundaries'.

 

If you wish to only see the melting cube while also playing with parameters, you can pin the viewport to the obj level. Go back to the obj level and toggle off the display of the AutoDOP node, and only keep the display on the 'box_object1_fluid' node. After that click on the pin icon (see image) to pin this viewport. Now if you go inside the AutoDOP again the viewport won't change and you'll be able to play with parameters while also viewing the mesh version of the melting cube. 

image.png.6ce5c8c86a27979f77599cfc7ef0e57d.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×