Jump to content

Karma XPU, objects out of focus / blurry


AntoineSfx

Recommended Posts

Using for example this material. so that we can eliminate this variable:

https://matlib.gpuopen.com/main/materials/all?category=Flooring&material=42a63f1c-93b1-4c27-a00f-abfc5480d898

The image is 1024 x 1024. I'm using Apprentice. This has to be done in Karma / XPU

Wembley_Chestnut_Flooring_baseColor.thumb.png.5477ce52621b5d7da65dfd3a4640cef4.png

The rendered texture is blurry, and I don't understand where the problem is coming from.

Are you able to get a result that is similar to the one you have on gpuopen after your click on the 3d icon ?

Link to comment
Share on other sites

There are a couple of things you can try. In the houdini.env file bump up the max texture resolution.

KARMA_XPU_MAX_TEXTURE_RES = "4096"

On the Image Output/AOVs (Render Vars) tab set the Pixel Filter Size to zero.

I have experienced improvements with these settings, but Karma doesn't give you a 1:1 crispness compared to the original texture.

Link to comment
Share on other sites

On 2022-11-06 at 6:20 AM, Atom said:

There are a couple of things you can try. In the houdini.env file bump up the max texture resolution.


KARMA_XPU_MAX_TEXTURE_RES = "4096"

On the Image Output/AOVs (Render Vars) tab set the Pixel Filter Size to zero.

I have experienced improvements with these settings, but Karma doesn't give you a 1:1 crispness compared to the original texture.

"Karma doesn't give you a 1:1 crispness compared to the original texture"

!! Do you mean render engines in general, or do textures render softer in Karma than in others?

 

Link to comment
Share on other sites

On 06/11/2022 at 3:20 PM, Atom said:

There are a couple of things you can try. In the houdini.env file bump up the max texture resolution.


KARMA_XPU_MAX_TEXTURE_RES = "4096"

On the Image Output/AOVs (Render Vars) tab set the Pixel Filter Size to zero.

I have experienced improvements with these settings, but Karma doesn't give you a 1:1 crispness compared to the original texture.

For what it's worth, I was able to get rid of some of the bluriness by deactivating Karma: Rendering / Camera Effect / Depth of Field

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...