Jump to content

Fatal error: Segmentation fault


letslie

Recommended Posts

hi. I installed Houdini 20 on a new PC and I keep getting crashes at random points during caching out bgeo of a pyro sim. I only get this error: "Fatal error: Segmentation fault"
it's not a matter of a corrupted scene - same thing happens on clean one with default pyro shelftool. the scenes also work on an older PC.
I tried reinstalling Houdini, installing other versions, updating drivers, changing HDD/SSD, recreating properties folder, and all other stuff recommended by SideFX for this particular error, like disabling some audio drivers.
I don't have any third-party addons installed. it's a new PC and its as clean as possible.
I doubt it's a matter of resources: I have 128GB ram, cpu intel core i9 14900K, nvidia rtx 4090, Windows 11. only CPU is at 100% during caching.
I also tried disabling E cores in bios.
I'm all out of ideas... any good and bad suggestions are greatly appreciated.
thank you!

 

Link to comment
Share on other sites

Sometimes new PC builds can take a while to "burn-in". Does your machine pass the Prime95 test? Try lowering your CPU overclock by a 1/2 step in the bios. It's easy to select a higher CPU setting, and most of the time the desktop will be fine. Also, I know it sounds like yeah right, but reseating RAM on the mother board has helped stabilize a few of the troublesome systems I've built over the years

Link to comment
Share on other sites

4 hours ago, letslie said:

thanks for replying but the whole point of me posting here was to diversify sources of information and possibly speed up the troubleshooting

SideFX is pretty fast and responsive with tickets. Sure you can try here but it could be anything.  There are multiple things that you can do, update drivers, it could be the RAM is faulty, your CPU, as Atom said if you are overclocking, do not. Do test for the RAM, stress out the PC, etc. Does it happen in another DCC? 

Link to comment
Share on other sites

thank you for the suggestions.
I didn't try any overclocking. at least intentionally - I'm not that technical. bios is mostly at default.
I haven't heard of the "burn-in" but I successfully ran the Prime95 through the night.
all drivers surely already were up to date.
ram seems to work fine but I reinstalled it anyway.

the error still occurs...

I'm not sure what DCC refers to. I tested rendering / caching in Maya and 2 other apps. all without problems.

a technical friend suggested that my motherboard, Z790 AERO G, is not great with my CPU, and suggested I get Asus Prime Z790-P. is it likely to be the cause? not the cheapest solution to test, but I spent much more on the PC I can barely use now.

 

Link to comment
Share on other sites

an update: I disabled hyper-threading and successfully ran few demanding sims.
I thought I had tried it before. either I was wrong or it didn't work in some combination.
anyway, not exactly a solution but a good work-around for now. dropped from 4.9 to 4.75 GHz on average.
I'll be running some more tests after the deadline.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...