Jump to content
marQiemarQ

Warning: invalid .mplay_lock file detected Help

Recommended Posts

I keep getting this error message when I try and ip render from a mantra node:

Warning: invalid .mplay_lock file detected

mantra: Could not open imager

I've gotten this error message in the past, but it would normally just go away after restarting Houdini. However, this time I get this error message every time I open a new Houdini session. I'm currently using Vista and I first noticed this happening around the time I installed SP2 last week. I'm not sure if these two are connected. I've tried to reinstall Houdin completely, which doesn't help. Does anyone know how to fix this problem or know a work around?

Thanks!

Share this post


Link to post
Share on other sites

Look for your $HOME/houdini10.0 directory and try renaming it.

Share this post


Link to post
Share on other sites

I tried to rename the $HOME/Houdini folder, which doesn't work for me. In fact, everytime I renamed the folder and kicked off another render, a new folder with the orignal name was created. One thing I noticed is that when I render, the .mplay_lock file appears in the $HOME/Houdini folder. Deleting this file doesn't do anything though. Any more suggestions?

Share this post


Link to post
Share on other sites

Hmm ...

- Which Houdini version are you running?

- Does it still render to mplay when this warning occurs?

- Try turning off your firewall. Does that improve things?

- Try setting the HOUDINI_MDISPLAY_WAIT_TIME environment variable to something longer than 60 (seconds) prior to starting Houdini. This tells Houdini how long to wait for mplay to start. It's possible that mplay is taking longer than 60 seconds? Maybe try values of something like 120 or 180.

- From the command line tools, run "mplay -background -render -K". This should create the lock file in $HOME/houdini10.0. Examine the contents of your .mplay_lock file in a text editor. The first number is a pid that should match the pid of your mplay process. You can check this my turning on View > Select Columns > PID in the Processes tab of the Windows Task Manager.

Share this post


Link to post
Share on other sites

I'm running version 9.5 currently, but the same thing happens on version 10.

To answer your questions: It does still render to mplay when the error message displays, but nothing will show in the render view.

I tried turning off the firewall for mplay, setting the HOUDINI_MDISPLAY_WAIT_TIME variable in the Houdini.env file, and I also verified that the PID number from the lock file matches the mplay proccess.

There is something weird happening because where it says Rendering #% at the top left, the numbers are overlapping. I've included a screenshot to show what I'm talking about. I also uploaded my Houdini.env file with the HOUDINI_MDISPLAY_WAIT_TIME variable set.

One more thing to note: The Houdini.env file didn't have any variables to begin with. I had to manually put the HOUDINI_MDISPLAY_WAIT_TIME in there. Is this normal?

post-4267-1240435445_thumb.jpg

houdinienv.txt

Share this post


Link to post
Share on other sites

i recently got what i believe to be the same error, but on winXP 32 bit.

but, in my case, i had just recently installed a new Security Suite.

digging thru the dialogs i was able to get to "Program Permissions" for the firewall and change all of the settings for all Houdini related apps from "Outbound-Only Access" to "Full Access" and no more problems.

Share this post


Link to post
Share on other sites

I ended up trying a lot of things to work around this issue. Oddly enough, the H8Mantra node works perfectly for me. I can render to ip with no issues. I'll try the "Outbound-Only Access" trick to see if that works too.

Share this post


Link to post
Share on other sites

Hey All

Im currently experiencing it with H11 and i cant even find the file under my houdini11.0 folder, or any folder for that matter.

This is under a Linux OS

Anyone else run into this problem ?

Cheers

Share this post


Link to post
Share on other sites

Hey All

Im currently experiencing it with H11 and i cant even find the file under my houdini11.0 folder, or any folder for that matter.

This is under a Linux OS

Anyone else run into this problem ?

Cheers

I encounter the same problem on my linux box at home, there it also applies if I fire of a Flipbook. In my case Houdini opens 2 mplay windows and the flipbook stops. The workaround that I've found, not convenient but it does work, is to close the second one, on the first mPlay window, click render and select disconnected. Now select listen for renders of flipbook depending on what your aiming at. Next in Houdini fire up the render or flipbook and it should work.

What I've discovered that Houdini fails to create the .lock file, this way you 'force' it to do it.

Hope this helps!

Btw, I totally agree with people who find this a very annoying bug ;-)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×