Jump to content
Sign in to follow this  
mikelyndon

Clear cache for a rop render

Recommended Posts

Hey guys.

I'm trying to render out the mesh for a particle fluid sim. When I first open the scene and start rendering out the bgeo files it takes about 7 minutes a frame but very quickly my RAM is used up and the frames start taking longer and longer to render - almost an hour a frame. I've tried setting the SOP cache limit to 512MB and changing memory to always in the main preferences but it doesn't seem to be helping. I'm assuming I need to clear the cache after each file is created.

I'm running this through a python shell as well to cut down on memory usage by the ui. I see the clear cache method hasn't been implemented yet in the hou module. I'm thinking of writing up a little script that opens up hython, opens the file, renders a frame, closes the file, and repeats the process. It's not an elegant way of doing things but I can't find another way to clear the memory properly after each frame has rendered.

Any suggestions would be greatly appreciated.

Mike.

Share this post


Link to post
Share on other sites

Ha! Hey man, it's Ben - I was looking for an answer to this just today and came across your post! Good times, good times :)

Share this post


Link to post
Share on other sites

have you unchecked 'cache simulation' in your dop object?

 

*edit

Sorry misunderstood the question.

 

Have you tried unloading all the sops you can? 

 

note: some sops you don't want to unload.

Edited by 3iart

Share this post


Link to post
Share on other sites

Seems to be an ancient topic by now. I personally do not see other solution then scripting sequence of 'load scene, GL render frame, unload scene' commands. I need to render my water simulation mesh using GL render just to daily it. That in my case would be faster then software-rendering the whole frame range. Everything works but RAM usage grows from frame to frame until Houdini crashes. And I have nothing fancy other then Cache SOP that reads the fluid meshes and some geometry processing after that before the final Null SOP that is supposed to be rendered.

Here is what I have tried to clear the cache:

1. Use 'sopcache -c' as a post frame script in OpenGL render. Or generally other combinations of flags on 'sopcache' command to restrict the amount of RAM used for cache.

2. Setting 'unload' flag on every SOP (including the final Null SOP) in my objects to be rendered. This can be done manually of with Python pre-render or pre-frame command.

3. Un-bypassing / bypassing SOPs with pre-frame and post-frame Python scripts.

Nothing works so far. Is there a reliable non-GUI way to clear Houdini memory cache ? Any other ideas ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×