Jump to content
Sign in to follow this  
kuaile_yzh

render flicking problem

Recommended Posts

Hi guys, recently there are some problems puzzling me. I made a simple particle network and copy it to metaball.So I make a simple explosion. But when I render it, the result seems flicking all the time. I wonder if there are any kind people helping me to figure out the problem.

untitled.mov

shansuo.hip

Share this post


Link to post
Share on other sites

well, at first it looked like a familiar issue from back in the day regarding shadow styles with deep shadow maps. A similar issue would come about when using the continuous option in certain situations, but now that's all gone with H9 and H10 and apparently the parameter is now considered obsolete.

So with that in mind, it could still be a shadow map issue, and very possibly a resolution issue. Your deep shadow maps are really low res (128x128) *and* your particles are only taking up a *very* small portion of your light's field of view. So in reality, the only thing useful in your maps are probably taking up around 16x16 pixels once rendered. Not very detailed for several thousand metaballs.. :)

Do a few things:

1. Increase your map res, let's say 512x512 for now.

2. Look through your light. Turn off the 'use cone angle for field of view' on the Light tab. Then reduce your projection angle so that it crops just the smoke in the scene at the point at which it's the largest. A value of 15 seems to do pretty well here.

3. Optimize it further by limiting your near and far clipping planes in your shadow tab so that it only encompasses what you need.

hth,

dave

Share this post


Link to post
Share on other sites

Dave,

I resolved the issue yesterday by changing the map resolution to 512x512 as well as lowering the shader density value.

In any case, thank you very much for your help.

Share this post


Link to post
Share on other sites

Glad you were able to resolve it. However, I would still optimize your maps by working with your field of view and clipping planes. At least with the field of view, you'll actually use the whole map for what it's worth. No sense in having a 512x512 map and keeping the field of view so that you're particles are only taking up 10% of the space. Might as well use the whole resolution of the map that you're generating..

Share this post


Link to post
Share on other sites

Thank you very much, in future productions, I will be sure to be more careful in regards to the shadow map. Again, thank you very much for your help and advice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×