Jump to content
Sign in to follow this  
marcosimonvfx

Flip Fluid collapsing

Recommended Posts

Hi there,

 

I'm having problems with the FLIP Fluids in Houdini. I'm trying to simmulate a kind of "empty-watercooler-over-head" effect and I can't get good results. Here is what I have so far:

 

https://drive.google.com/open?id=0B2Ra4vnwxtl_VDQ4aUQ2TUZON2s&authuser=0- this is the result with the default values for seperation and grid scale etc. (few particles for the sake of sim times) As yo see the particles collapse over time.

 

https://drive.google.com/open?id=0B2Ra4vnwxtl_Tml3dWpaaFctSEU&authuser=0- this is the flipfluid with adjusted parameters. Particle Radius scale is up to 2, Grid Scale is down to 0.5 (3 Substeps of the DOP Network) - this would be fine but the problem is that it takes FOREVER to simmulate (i guess bc of the gridsize) and doesn't scale well. Sim times shoot up fast and also at some point the particles start collapsing again and I would need to adjust the parameters - which is an ordeal with simtimes that high (above 10 hours for less than 400k particles). To compare:

 

https://drive.google.com/open?id=0B2Ra4vnwxtl_bEFMVzg2YlhMajA&authuser=0- This is what I get with the old Flipsolver (not the 2.0). This doesn't look like much but it scales really well:

 

https://drive.google.com/open?id=0B2Ra4vnwxtl_VjZla29oVVVHZ0k&authuser=0- this took just a couple of minutes to simulate and looks already very good. Over night I did another sim with even more particles and it looks exactly like I want. Cool, nice splashes and good collision behavior.

 

Unfortunately the old flipsolver lacks solving for viscosity and friction etc. which is why I would prever the 2.0.

 

Is there just some parameter that i'm missing - I played around with this forever and also get the same errors (fluid collapsing) in quickly setup scenes with a quickly modeled bowl as container.

https://drive.google.com/open?id=0B2Ra4vnwxtl_RDluQ08zM1pwd0k&authuser=0- here's the scene, though the cooler is normaly an alembic so I just substituted it with a tube in this file. The problem is the same.

 

Cheers!

 

 

Share this post


Link to post
Share on other sites

In my experience this is usually a grid scale issue. Grid scale of 0.5 seems very low (I think the default is 2). Try reducing it from 2 in smaller increments. Perhaps start at 1.9 or 1.8 and test from there.

Share this post


Link to post
Share on other sites

Thanks! I tried that. For mid res simmulations this is a good value and I can even scale up a little with the resolution. But when I tried to sim with the final particle count it collapsed again. Is that the only parameter I can adjust? Why does the old flipsolver then is so fast compared to the newer one even when I disable the evaluation of viscosity and friction 0.o

Share this post


Link to post
Share on other sites

With FLIP sims, the particles carry the volume of the fluid with them, so you really can't cheap-out on them for the sake of simulation times... If at any point you have a situation where a grid cell of fluid isn't covered by at least 1, ideally 2 particles, that part of the fluid will collapse, as it has nothing to define it.  Not to mention the fact that the particles define the fluid visually too - to get the optimal look with the most surface detailing, you need to create a VDB-from-particles.  Particles define the shape, the grid defines the motion... you need both in balance to get the right look.

 

The default Particle Radius Scale of 1.2 is pretty much ideal.  If you reduce it, the fluid will collapse, if you increase it, you'll just end up with it looking blobby and having very little fine detail in the motion too.  I would recommend not changing it unless you really need to.

 

Grid scale of 2.0 is fairly typical too.  All it means is that you're defining one voxel for every 8 particles (2.0^3), as you can get away with that much less velocity resolution compared to particle resolution.  Again, unless you feel the need to have particularly detailed or vague velocity, I'd recommend not changing it.  Definitely never reduce it lower than 1.0, as then you'll end up with MORE voxels than particles, which will be horrendously slow, and likely cause collapsing too.

 

That pretty much just leaves particle separation.  Set that to whatever you want... it's the catch-all master resolution setting.

 

In general, expect LONG simulation times, and HUGE memory usage.  That's fluid simulation, there's really no avoiding it if you want a detailed sim - FLIP is a lot faster than just about any other way of doing liquid simulation, but it's certainly not fast.  Sims will take hours, not minutes.

In general you want to be aiming for at the very least hundreds-of-thousands of particles, if not millions for any reasonably large-scale sim.  Even for 'quick' test run, you simply won't get any useful impression of what the final sim will do unless you rack it up to at least a couple of 100,000 particles.

 

 

Lastly, I'd suggest you set the substepping on the FLIP Solver node, not on the parent DOP Network.  FLIP sims have their own internal substepping, and it can be variable if desired.  I'm not certain whether using DOP substeps would actually make any visible difference, or inhibit the solver in any way, but you may find it's a hint quicker as there may be things that FLIP only selectively substeps internally, where DOPs will substep the entire network.

I'm not personally a fan of variable substepping, as I find the way it changes the behaviour of the sim is a little too unpredictable.  In that case, you'd set Min Substeps and Max Substeps both to the same value.

 

Looking at your clips, I'd say your substepping value of 3 is probably about right for the amount of action going on.

Edited by danw
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×