Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
malik

per object render quality

Hello everybody

 

cant get to implement "per object render quality" as mentionned in the documentation. (pbr)

 

Tried to add rendering  properties, parametter,s attribute,s at object level, geometry level, shader level... Nothig seems to work...

 

Is there realy a way to improve rendering on a per object (primitive, shader) basis with mantra PBR ?????

 

THX

 

P.S. If it is possible I would say it's prety badly documented.... 

Share this post


Link to post
Share on other sites

Hi Malik,

 

Just had a quick look and the docs do say that you can't set the pixel samples on a per-object basis, only the ray samples.

The sampling quality slider should be working... Remember that you're unlikely to see any dramatic difference in quality it there is a 'bottleneck' elsewhere in the render settings, i.e. cranking the ray samples really high won't help too much if you pixel samples are set really low, so if you're rendering at 3x3 you won't notice the difference between two object with vastly differing ray samples

 

H

Share this post


Link to post
Share on other sites

Thanks for you answer Peon...
 
Of course I didn't try to set the pixel samples
 
I tried mainly with vm_variance & vm_maxraysamples at object, primitive, shader level and could not get any of them working with no visible effect in the image itself nore in the diagnostic passes (direct samples for example)... 

obviously I must be missing something..... 

here a simple not working test with vm_variance especialy make that the enhancement sould be obvious; Put the noise level on the mantra node at .5 and at .01 on the object.... No difference whatsoever. especialy in the direct raysample pass. And there should be a difference as if I make two renders with this mantra node (without the attribute on the object) there is an obvious différence betwin noise at .5 or noise at .01, at .5 the ray count stays at 1 at  .01 the ray count os going higher in regions where it is necessary.

Share this post


Link to post
Share on other sites

I'm also having difficulty with this. Same deal - tried adding parameters at object level, directly in the shader, etc., no change. I'm using exactly the same procedure as in the scene Marty posted, with no effect. I'm wondering now if this might be a platform / version-specific bug? I'm on Houdini 14.0.474, OS X. 

 

I've attached some renders of a simple scene. From left to right:

 

- Two spheres with default Mantra Surface material, default Mantra PBR rendering with HDR lighting.

- Max Ray Samples increased to 20 in Mantra, knocking out a lot of the noise in the reflections. 

- Max Ray Samples taken back to default in Mantra, added a Max Ray Samples parameter to the left sphere and bumped it up to 20, identical result to first render. 

 

I've attached my test scene, just replacing the HDR with a simple Sky Light if anyone wants to take a crack at seeing if it works for them. 

post-10283-0-81027700-1460224623_thumb.p

post-10283-0-75697100-1460224625_thumb.p

post-10283-0-63877400-1460224627_thumb.p

render_prop_test.hiplc

Edited by jrockstad

Share this post


Link to post
Share on other sites

It definitely works to decrease the sampling per object, see blue sphere in picture. Set the maximum in Mantra, then set the lower quality per object. If it's meant to also be able to increase the quality per object, then that seems like a bug or Rfe. Please send that into SideFx.

 

OsX, H15.0.441

post-8321-0-01998800-1460252547_thumb.pn

render_prop_test.hiplc

Share this post


Link to post
Share on other sites

Thanks Marty, yeah, I also had the hunch after looking over your scene that perhaps the intended workflow is to set the maximum ray samples in Mantra then use object / shader parameters as limits. The documentation seems to imply it should be able to work in the other direction as well though:

 

 

  • You can add sampling properties to an object to get separate per-object pixel settings. This lets you specify very high ray samples for a single "hero" or problematic object instead of increasing pixel samples globally. Note that the pixel samples cannot be changed on a per-object basis - only the ray samples.

 

I ran a couple more tests with some interesting results. First image has Max Ray Samples set to 1 in Mantra, second has 20 in Mantra and 1 on the blue sphere. You can see that some parts of the sphere are very noisy while others are quite clean. If I remove the ground plane, the blue sphere is almost totally clean, with just a bit of noise where it's being occluded by the orange sphere, so I'm assuming that some kind of importance sampling is going on here where the object is still getting more rays where it is directly visible to bright areas of the environment even with a very low Max Ray Samples setting. I cannot find any documentation on this behavior though, so I would be happy to hear from anyone with more insight on this.

 

In any event, setting per object Max Ray Samples to a higher amount than specified in Mantra still seems to have no effect, so I'll go ahead and submit a bug report to Side Effects on that one. 

 

 

post-10283-0-47326300-1460318209_thumb.p

post-10283-0-37727400-1460318215_thumb.p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0