Jump to content
Sign in to follow this  
jimmay

Pulsing pyro

Recommended Posts

Hi guys,

 

Attached is a scene that does something nobody here can explain.  It's a fairly simple pyro sim intended to look like a plasma trail from a damaged spaceship.

The thing we can't explain, is the fact that it pulses out every 50 frames.  Load up this scene, and render frames 51, 101, 151 and the frame renders black.  Render the frames around it (or render the whole thing) and you'll see the element simply drops to black for several frames, then recovers for several frames after.

The only thing we do that affects it is to shut off the Noises on the fields in the Pyro shader.  No amount of messing with the parameters therein has affected it; the 50 frame period is constant.  There are no animated properties in the scene that have it either; the spinning emitter runs from 1 to 120.

The issue is the same with H16 style Pyro shader, and with the earlier H15.5 pyro in shopnet when it's set up with similar settings (both are present in the attached scene).

I'm using those noises b/c for the life of me, I can't find any way to do detailing displacements of volumes at the shader level after the fact - googling such just gets me hits on how to do it for Arnold, or in the older shopnet.  I'm very much a noob, and mostly have done shader work in H16's new context.  

My supe likes the results we have here, but if I shut off the Pyro shader field noises I lose the look.

Any help appreciated - including workaround pointers on how to do my own volume displacements in shaders, post-pyro sim.

Trail_v04.hip

Edited by jimmay

Share this post


Link to post
Share on other sites

As far as I know the pyro shader uses the 'rest' and 'rest2' fields as a position input for the noise. It doesn't look like you are computing those fields currently in the sim, you can turn that on by going to the Pyro Solver>> Advanced Tab>> Rest Field Tab and enabling it.

The black renders at 50 frame intervals reflect the default 50 frames that the rest fields take to cycle. 

Share this post


Link to post
Share on other sites

ARGH, that's it.  Thank you Malf.

For reference should any other noobs run into this: there's two places to switch on rest fields: on the container (smoke object) "Add Rest Field" under "Initial data", and on the pyro solver under the "Advanced" tab, "Enable Rest" - this is also where the other controls for rest are located.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×