Welcome to od|forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
bloodfar

Flip displacement (soooo long)

Hello, 

 

I have a flip mesh with 2Millions polygons and I want to add an ocean spectrum to it in displacement.

But why it takes like 20 mins to "create the displacement geometrie" and take 13Go of RAM in mantra ??

It's not really easy to tweak the shader with this time of preparation ....

I'm beginner with mantra, Arnold is much faster to do this, so I think I'm doing something bad ... 

(I use the spectrum and the ocean surface shader from houdini 16)

 

Someone can help me ?

 

Thank you ! :):) 

PS: sorry for my English :(

 

Share this post


Link to post
Share on other sites

The resolution of your grid does not change the resolution of the render time displacement. Only texture maps define resolution.

You could use the shader on a grid that has only 4 points, and will render same quality as 2 million.

The only difference is rendering with motion blur. Mantra needs enough points with v attribute to calculate motion blur.

So loading 2 million points is heavy and useless. Just have enough points to get accurate motion blur or use 4 point grid if your not using motion blur.

Edit: sorry, you are working with flip mesh and i thought only ocean grid, so this is not a solution

Edited by Yon Anadeyo

Share this post


Link to post
Share on other sites

Hey,
If the object has "Render polygons as subdivision (mantra)" selected, your generation time will be very long.
I have found that specifically with the flattank setup, leaving that unchecked significantly speeds up the generation of displaced geo and looks pretty much identical.

Hope this helps,
Matt.

Share this post


Link to post
Share on other sites

Thanks for your answers.

The "Render polygons as subdivision (mantra)" box is unchecked on my objects.

My flip mesh is about 2Millions polygons.

 

Maybe It's just normal for mantra, but to tweak shading and lighting it's a bit tricky ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0