Jump to content
Sign in to follow this  
rodpacker

"particleFluid - staticRBD" collision distance to high

Recommended Posts

Hi guys,

I'm needing to fill a logo with liquid and choose particle fluids as they seem to give me the nicest splashes. As it is a logo it needs to be represented possibly accurate.

Luckily on this one I should get away with a fairly low-res particle count. I am having two problems with this:

1. if I use a fairly low particle separation of e.g. 0.25 the particle fluid seems to be blocked from falling down through my e.g. "S" (see attachment) as if the staticRBD collision wasn't set up right. However looking at it (by displaying) it shows the collision geo just fine. Also if I use a higher particle res e.g. particle separation of 0.1 the flow is just fine.

Can anybody tell me what that is and how to fix it? Or do I just have to use the higher particle res?

2. as shown in attached image, the particles don't seem to be colliding right on the border of the collision geometry rather then having something like a buffer zone (marked bright green in a few areas in the screenshot) I have looked into various options to fix this and came up with:

- the VOLUME OFFSET under the collisions TAB of the particleFluid-DOP, but I cannot seem to b able to set a negative value in order to get it closer to the actual RBD geo borders

- the OFFSET SURFACE setting in the collision->volume tab of the static RBD I am using, but looking at the font and the fact that then the letters would cut into each other doesn't make me think that's the way to go either

As a last back up I guess I could have a relatively wide (e.g. high Point Radius Scale or Surface Distance in the particle fluid surface SOP) mesh and then subtract over-standing geo with a cookie node and the original font. However this does seem to be more of a "Maya-solution" rather then the logical work flow I am used to from Houdini.

Is there a "reduce collision distance" - slider somewhere I haven't found? Or what other ways can be used to do this?

cheers for ur help

rodpacker

post-3795-125360676293_thumb.png

Share this post


Link to post
Share on other sites

I posted this to the SeSi-forum as well and Michiel got back to me with the following:

Hi,

The collision code for particle fluids looks at the "pscale" point attribute.

However, the amount of separation between the particle centers and the geometry seems to be double the amount that is required here.

This is logged as bug 37138.

Until this is fixed, the simplest workaround is to reduce the particle separation.

While I was running tests on higher particle count over the weekend - not expecting such a quick fix he had already posted this a day after his first reply:

A fix was included in Houdini 10.0.410.

This fix reduces the buffer zone between the particles and the geometry,

so you shouldn't have to decrease the particle separation.

Michiel

That's what I call great customer service and support :)

THX SideEffects

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×