Jump to content
ChristopherC

Weird result when compositing smoke with deep comp

Recommended Posts

Hi!

 

I'm getting started with rendering and decided to use render passes to then composite my final image like a pro in Nuke. I read that deep compositing is the way to go when an object goes through a volume so I've enabled the deep camera map setting for both my object (a box) and the volume (some smoke). For comparison, I added a “beauty” pass to represent what the final composition should look like. See the attached hipnc file.

 

I also have no previous experience in compositing but I think having managed to get things working in Nuke, as per the network below.

 

post-12907-0-84648600-1433426205_thumb.j

 

 

The final composition seems to be identical to the beauty pass at the exception of the volume outline which differs.

 

post-12907-0-40105500-1433426203_thumb.j

 

 

The beauty render (on the left) shows a slightly bigger volume than the one composited (on the right). When viewing in Nuke the dcm image rendered for the smoke, the outline seems to be slightly smoothed out/contracted. Any hint to what this difference could be due to?

 

 

Cheers,

Christopher.

 

smoke_composite.hipnc

Share this post


Link to post
Share on other sites
Guest tar

Change DeepMerge to Combine. Delete everything after DeepToImage.

Share this post


Link to post
Share on other sites
Thanks for your help!

 

Are you saying that I should consider the “DeepToImage” node as being the final image to output? If I do as you say, how would I go to split my render into diffuse, specular, and other passes, while still being able to use this deep data as a way to combine each layer from all objects?

 

Below is the view of the beauty pass (on the left) in comparison to the “DeepToImage” node with the “combine” setting enabled (on the right). I guess more samples would help, but I still have the same issue.

 

post-12907-0-38961700-1433467845_thumb.j

 

 

As for the image below, it shows the difference between the smoke render (on the left) with its dcm version (on the right). We can clearly see a stroke on the right side, meaning that the dcm area is smaller than what it should be.

 

post-12907-0-67087200-1433467841_thumb.j

 

 

This difference is why I suspect that I'm doing something wrong at the rendering stage in Houdini.

 

Share this post


Link to post
Share on other sites
Guest tar

If you want the deep composite to be exactly like a Beauty pass then you will need to render the individual passes with the other 'hidden' elements as phantom. 

 

Use DeepRecolor node to add back into the Deep chain any colour corrections you do to the individual passes . i.e. spec etc.

 

Sorry, haven't had time to investigate the differences in the dcm and smoke render.

Share this post


Link to post
Share on other sites

Regarding the render passes with the other objects set to phantom, I think that's more or less what I've been doing in the attached scene? I'll take note of the DeepRecolor, thanks!

 

As for the main issue I'm having, I'm still clueless—anyone? :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×