Jump to content
a42b

transparent material with reflection but no refraction

Recommended Posts

Posted (edited)

Hi. Nooby question:

I need a transparent material that reflects light but does not refract it. I could not achieve that with the principled shader. If I turn transparency to 1, I get a transparent material. Through the IOR parameter I can control the the intensity of the reflection AND the refraction. Is it possible to turn off the refraction but keep the relfection and transparency?

Thanks for your help.

Edited by a42b

Share this post


Link to post
Share on other sites

Hi,

Principled shader doesn't offer much options for tricks like this so I'd say there is no convenient way how to do this with Principled. With Classic shader thou, you have an option whether to refract objects and whether to refract lights. Also, you can turn off an IOR for refractions. That might do what you're looking for.

Share this post


Link to post
Share on other sites

Thanks for the tip. But unfortunately the Classic Shader behaves in the same way as the Principled shader. If I change the IOR to 0 the reflection also disappears.

What I would like to achieve is just rendering the reflections without any diffuse component. The diffuse part should be transparent. Can someone please point me into the direction how to do that from scratch?

Share this post


Link to post
Share on other sites
Posted (edited)

yeah, IOR affects reflection and refraction in the same way. what you want to do is to enable Thin Film Refraction option under Refract tab in Classic shader. That basically sets refraction IOR to 1 while keeping reflections untouched.

removing diffuse component is easy, just untick Enable Diffuse in the shader diffuse tab.

if you need even more control you can mix two shaders with use of Mix Layers VOP (mixing PBR Reflection VOP and PBR Refraction VOP works just fine for situations like this - no need to use complex shaders like Principled or Classic)

Edited by davpe

Share this post


Link to post
Share on other sites

Enabling the Thin Film Refraction option did the trick.

Thank you so much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×