Jump to content
tagosaku

bullet dynamic emission does not work properly

Recommended Posts

hi, I try to learn to dynamically emit packed objects in bullet sim. So far, emission seems to be fine, but the scale of each piece object are wrong. I tried to set RBD packed object > bullet data > geometry representation BOX and convex. Then display geometry and show-guide-geo don't match, too. I have no idea what's required to do dynamic emission properly. 

I attached example file. If anyone tells what to fix, I appreciate it, thanks. 

bullet_dynaEMission.hip

bullet01.PNG

bullet02.PNG

Share this post


Link to post
Share on other sites

Try this

-Reduce the box scale while copying onto the points (in your scene they are heavily interpenetrating)

- DOP/RBD PACKED OBJECT : Initial object type: Create active object. (your source is not animated in terms of position, if you set it to deforming source the dopobject will try to figure out where that source geo is moving, but you have a changing topo source, hence the position is mismatching)

-Turn on AutoFit Primitive boxes toggle in DOP. (this will make sure your collision geo fits properly)

Does that help?

 

 

image.thumb.png.a0be3273e8744de6476a5d574a60bc2a.png

Share this post


Link to post
Share on other sites

To WLVL Daivd

Sorry for late reply. Using 'create active object' fixes all my problems, thanks!! Basically the both of  'create deforming active/static object ' selections kill my setup. 

Also, I did not mean to use 'create deforming active object ' , but just forgot to select 'create active object.' by human error. I hate there are so many check-list to sim bullet properly. 

Anyway, thank you so much again!!

Cheers! 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×