Jump to content

Filecache with Daily (TOPs issue)


Recommended Posts

Hey, in order to make work on our diploma project easier, me and a colleague developed a slightly advanced filecache simplifying the process of iteration for us and junior artists.

Now to make reviewing easier, I want to simultaniously output an OpenGL-render for every frame after the geo is done. In ROPs this is super easy and my standard setup whenever I am developing some FX.

This is the general layout:




Since  for this filecache I am relying on TOPs to make outputting quicker and more streamlined, I am now facing the issue that I can't get the ROP-Fetch to replicate what normal ROPs would do. I deliberately don't just put a ropgeo-TOP and a ropfetch with just the daily after each other because that has to start a seperate Houdini instance just for the OGL-render, which is extremely inefficient, as the render itself takes just one or two seconds - and I don't want to increase the batch size either, since that would cause a delay in the OGL-output after the sim is done. I just want it to output it right after each frame is cached. With two ROPs after each other, this works wonderfully in my experience.


In either of the following two layouts the ROPnet would do what I want, which is output one frame of the GEO-ROP and one frame of the OGL-ROP one after the other:


Unfortunately, now what happens with the ROP-Fetch in TOPs in the exact same layout is that apparently the very first work item already renders out the entire sequence.

In the two days of debugging that I've invested so far I've tried loads of things that came to my mind, one being just using the pre-built ropgeo-TOP-node and inputting my daily-ROP there. However, there, even weirder behaviour happens. If aligned like above, it simply ignores the OGL-ROP and if I ROP-Fetch just the OGL, the very first work item outputs the full frame range and all other work items are ignored.


Either I missed some hidden settings in the thousand times that I went over it or this stuff is a bit buggy. I'm hoping for the former.



EDIT: Alright, after chatting with support, it turns out that the python updating the comment of the parent node was causing the crash. :D
Well, have to go without this nice UI thing then...

Edited by tortoise
Solved :)
Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...